Application window is off the screen...

Posted:
in Mac Software edited January 2014
and I can't move it back!



I use the F9 key to show all my open apps and one of the apps I have open is off the screen! and I can't find a way to drag it back. I used to have the laptop connected to second monitor creating duals which might explain it but once you take off the second monitor shouldn't all the apps show on the main screen??



If this has happened to anyone let me know!! I'm trying to find a way to fix it.



Thanks!!

Comments

  • Reply 1 of 5
    cakecake Posts: 1,010member
    System Preferences -> Displays



    With the Application Folder open (even if it is off-screen) try switching the screen resolution to another size, then switch it back. The Applications Folder should pop on to your monitor.



    I get Pro Tools sessions with windows off the edge all the time from other facilities and this fixes the issue for me.



    Good luck!
  • Reply 2 of 5
    o-maco-mac Posts: 777member
    Quote:
    Originally Posted by Cake View Post


    System Preferences -> Displays



    With the Application Folder open (even if it is off-screen) try switching the screen resolution to another size, then switch it back. The Applications Folder should pop on to your monitor.



    I get Pro Tools sessions with windows off the edge all the time from other facilities and this fixes the issue for me.



    Good luck!



    Hello. I tried it but it didnt work. It's not actually the applications folder but the application itself that is off-screen.
  • Reply 3 of 5
    mydomydo Posts: 1,888member
    I hate when that happens.



    Try to use the menu "Window" to "zoom" or something. Maybe it will come back.
  • Reply 4 of 5
    cakecake Posts: 1,010member
    OK, I did some searching then did a little test and this worked for me:



    Copied from the site:
    • 1: Click on the little Apple icon at the top left of your screen

    • 2: Click ?System Preferences?

    • 3: Click ?Universal Access? (icon is a stickman in a blue circle)

    • 4: Click ?Enable Access for Assistive Devices? (at the bottom)

    • 5: Exit System Preferences

    • 6: Open ?Finder?

    • 7: Click ?Applications?

    • 8: Click on the ?AppleScript? folder

    • 9: Open Script Editor?

    • 10: Copy this script into the editor and run it and you?re done.

    Here's the script (copy and paste the bold text into Script Editor):

    -- Example list of processes to ignore: {"xGestures"} or {"xGestures", "OtherApp", ...}

    property processesToIgnore : {}



    -- Get the size of the Display(s), only useful if there is one display

    -- otherwise it will grab the total size of both displays

    tell application "Finder"

    set _b to bounds of window of desktop

    set screen_width to item 3 of _b

    set screen_height to item 4 of _b

    end tell



    tell application "System Events"

    set allProcesses to application processes

    set _results to ""

    repeat with i from 1 to count allProcesses

    set doIt to 1

    repeat with z from 1 to count processesToIgnore

    if process i = process (item z of processesToIgnore) then

    set doIt to 0

    end if

    end repeat



    if doIt = 1 then

    tell process i

    repeat with x from 1 to (count windows)

    set winPos to position of window x

    set _x to item 1 of winPos

    set _y to item 2 of winPos



    if (_x < 0 or _y < 0 or _x > screen_width or _y > screen_height) then



    set position of window x to {0, 22}



    end if

    end repeat



    end tell

    end if

    end repeat

    end tell






    It's a bunch of steps, but it seems to work.
  • Reply 5 of 5
    MarvinMarvin Posts: 14,200moderator
    Deleting the application preferences should do the trick too but obviously means losing your application prefs. I reckon window location should be stored in there, although why it wouldn't reset the location to being inside the screen resolution on restarting the app I don't know. What application is it?
Sign In or Register to comment.