Quicktime can't update--permissions

Posted:
in Genius Bar edited January 2014
I'm relatively new to mac, so patience please.

The software updater keeps indicating an upgrade to Quicktime which won't install b/c "The update can't be saved. You don't have the appropriate access priveleges." What's up with this? The other update available was an iMac EFI Firmware Update that gave no problems and yet for the QT update, it seems to be something I should need root or admin priveleges to do. Why is QT finicky?

thanx

Comments

  • Reply 1 of 2
    MarvinMarvin Posts: 14,217moderator
    You don't always need to upgrade Quicktime and sometimes it's better you don't. I had to upgrade to the latest Quicktime to run a certain app and now my MPEGs don't play audio.



    Anyway, you can download standalone versions if the software updater isn't working, from:



    http://www.apple.com/quicktime/download/



    If there's a permissions issue, you can try repairing permissions using Disk Utility.
  • Reply 2 of 2
    aegisdesignaegisdesign Posts: 2,914member
    Delete the /Library/Updates/Quicktime folder and try again or download it normally and install it that way.
Sign In or Register to comment.