Forcing Cube Ethernet to 100baseTX, full duplex?

in macOS edited January 2014
Did anyone succeed in forcing their Cube's ethernet interface mode to 100baseTX, full duplex in MacOS X (I'm running 10.1.5 here)?

The switches in use here don't support autonegotiation so they are configured for 100baseTX fdx operation by default.

I'm trying to change the interface setting with the (undocumented in OS X, but documented in the FreeBSD man page) following command:

ifconfig en0 media 100baseTX mediaopt full-duplex

ifconfig doesn't complain, but after checking the settings again, ifconfig still displays half-duplex. I already tried compiling ifconfig from the Darwin source repository by hand but this didn't help either.

Does anyone have an idea how to configure the interface to full duplex (without hacking the GMac driver ;-)). Is there maybe some undocumented OpenFirmware variable I can set (similar to some SparcStations)?


Sign In or Register to comment.