CD/DVD will not mount or eject.

in Genius Bar edited January 2014

I have an iMac 24" aluminum model (2.8 Ghz, Intel Core 2 Duo, 4 GB RAM, OS X 10.5.4) that I purchased in November of '07.

Within the last 2 to 3 weeks, I have loaded both a blank DVD and (once the DVD finally popped out) a factory-burned CD. The DVD would neither mount nor eject, despite trying every trick (holding the mouse button or eject key during start-up, "zapping" the PRAM, running repair verifications) that I could think of. It just suddenly popped out one morning during start-up (I think this happened because I had unplugged the power from the wall, but I have not been able to replicate this phenomenon with the stuck CD).

Anyway, I am nearly at wit's end! I can hear the Superdrive moving at power-up, and I have heard it try to mount the stuck CD, so the drive physically works. It's not making any strange noises...but it doesn't show up in the System Profiler.

Has anyone else encountered this? If so, were you successful in ejecting the CD/DVD? How did you do it? Thank you for your time!


  • Reply 1 of 4
    cyloncylon Posts: 126member
    You weren't by chance using Parallels and had the machine paused at the time did you?
  • Reply 2 of 4
    Originally Posted by cylon View Post

    You weren't by chance using Parallels and had the machine paused at the time did you?

    Thank you for your response! No, I do not have (to the best of my knowledge) Parallels on my machine.

    I do have, however, a FW800 drive (WD My Book 1 TB), a FW400 drive (LaCie 500 GB), and an iPod attached to the machine. Thinking the machine might be straining to supply power to all of these peripherals, I unplugged them and started up the machine. No luck.
  • Reply 3 of 4
    I'm also having this problem. Put in a DVD and it wouldn't mount, then tried to eject and wouldn't eject.

    This worked for me to get the disk to eject:

    In Terminal, run the command 'drutil tray eject'.
  • Reply 4 of 4
    go 2 the apple store and it will b fixed
Sign In or Register to comment.