iTunes 8 quit playing music -files are there.

Posted:
in iPod + iTunes + AppleTV edited January 2014
I've seen a few threads on apple.com about this happening to windows users, but didn't see any for mac users.



My iTunes 8 has been working flawlessly since this morning...



setup: iTunes 8 on Macbook Pro, library is on a shared FAT32 drive on my network. (windows home server machine shared drive). I've hosted the files on this server for over 1 year without issues.



iTunes can see the drive, can add new files from and to the drive (these happen to play).



I've rebooted, fixed permissions, I've re-installed iTunes, remapped the music location...no tunes. All I have is the 'play' button and it does nothing for anything other than the one added album that I used to test with.



Any advice? Very frustrating to wake up to this.

Comments

  • Reply 1 of 3
    sandausandau Posts: 1,230member
    even worse, now if i open up iTunes its starting to remove all the songs from my Apple TV. What's next? This is awful. The last thing I want to do is sync 38gb across wireless (if I ever get it working again.).



    This iTunes 8 is starting to feel just like Junk, cept not as hairy.
  • Reply 2 of 3
    MarvinMarvin Posts: 14,229moderator
    What you could try is unplugging your ATV to avoid the sync, hold the alt-key while launching itunes. Then create a new library at the dialog and then uncheck copy music in your advanced preferences. Then just drag your folder of music onto itunes. It shouldn't do any copying but it will build a new itunes library. You will likely lose info like song ratings and play count but the tags such as album names etc should be intact.
  • Reply 3 of 3
    sandausandau Posts: 1,230member
    good suggestion, thanks. I'll give that a try.



    I also ripped the drive out of the home server and ran disk utility against it again. this time it came up with `..' entry in /iTunes has a non-zero start cluster...which it fixed, so i hope it'll work....



    update: the disk utility fixed it the second time around.
Sign In or Register to comment.