2nd Gen iPod Touch Problem, HELP!

Posted:
in iPod + iTunes + AppleTV edited January 2014
alright so i got my 2nd gen ipod touch, yeahhhh.. anyways the wifi wont work.. its connected to my home wifi network, which is working as i tested it with my brothers 1st gen ipod touch, a laptop, and my pc using a usb wireless adapter. when i try to go on the internet it says "Cannot Open Page Safari cannot open the page because it is not connected to the Internet" but when i go into settings it shows that is is connected, WHAT CAN I DO!?

Comments

  • Reply 1 of 7
    irelandireland Posts: 17,223member
    Call Apple, demand a replacement. They'll hand one over right away.
  • Reply 2 of 7
    I don't know how you handle security on your home wifi network, but I don't use WEP, I use MAC access control. If you use WEP, you'll have to set it up accordingly on the Touch. If you use MAC access control, you'll have to add your Touch to the list of approved devices. If you use both, you'll have to do both.
  • Reply 3 of 7
    To me it seems as if there is a connection to the access point, but TCP/IP settings are messed up.

    Check your settings regarding DHCP, your DHCP server or adjust things manually.

    I don't think that your iPod is broken...
  • Reply 4 of 7
    i think you try to restore the firmware and see....

    download the new firmware ...whatever is same version of the firmware...

    try restore it.... maybe will work...... good luck





    Quote:
    Originally Posted by Xxplosive View Post


    alright so i got my 2nd gen ipod touch, yeahhhh.. anyways the wifi wont work.. its connected to my home wifi network, which is working as i tested it with my brothers 1st gen ipod touch, a laptop, and my pc using a usb wireless adapter. when i try to go on the internet it says "Cannot Open Page Safari cannot open the page because it is not connected to the Internet" but when i go into settings it shows that is is connected, WHAT CAN I DO!?



  • Reply 5 of 7
    Quote:
    Originally Posted by Xxplosive View Post


    alright so i got my 2nd gen ipod touch, yeahhhh.. anyways the wifi wont work.. its connected to my home wifi network, which is working as i tested it with my brothers 1st gen ipod touch, a laptop, and my pc using a usb wireless adapter. when i try to go on the internet it says "Cannot Open Page Safari cannot open the page because it is not connected to the Internet" but when i go into settings it shows that is is connected, WHAT CAN I DO!?



    I had exactly the same problem - my ipod Touch said it was happily connected to my wireless router but yet I was unable to access any web based services using Safari, YouTube, App Store etc. I tried all the various suggested fixes on a number of forums and nothing seemed to work.



    In the end, it seems that the problem related to some sort of DNS incompatability. My ipod was collecting my standard ISP's DNS server entries from my router (in my case this is Orange) - and whilst these DNS Servers seem fine for my PCs, they don't seem to work for the ipod.



    It's quite easy to check if DNS is the problem for you. If you open up Safari and instead of browsing to www.google.co.uk - try entering the Google IP address instead ... 208.69.34.230 - if this opens the Google page but entering 'www.google.co.uk' doesn't, then you have a DNS problem.



    Therefore in my case, I looked up alternative DNS servers - I used the server addresses offered by http://www.opendns.org Their DNS server addresses are 208.67.222.222 and 208.67.220.220



    I edited my router settings (the method to do this will depend on your particular router) and changed my existing Orange DNS server addresses to the new DNS server addresses above. I think I then 'forgot' my current ipod connection to my wireless router and then reconnected it to pick up the new DNS entries (but this step may not have been necessary).



    Since I've made this change, I've had no problems using any internet based services on the ipod through my wireless router



    Fingers crossed, that this helps you and/or others ... let me know if it does?
  • Reply 6 of 7
    flynikeflynike Posts: 1member
    Quote:
    Originally Posted by AndyBest View Post


    I had exactly the same problem - my ipod Touch said it was happily connected to my wireless router but yet I was unable to access any web based services using Safari, YouTube, App Store etc. I tried all the various suggested fixes on a number of forums and nothing seemed to work.



    ... try entering the Google IP address instead ... 208.69.34.230 - if this opens the Google page but entering 'www.google.co.uk' doesn't, then you have a DNS problem...



    Fingers crossed, that this helps you and/or others ... let me know if it does?



    Andy--I can't thank you enough. I joined this forum just to tell you how great your advice was!



    I just got a 2nd gen on ebay, and it seemed to be working great. Then the wireless trial, and...



    I saw that damned "wireless connected" icon, yet nothing would load. My 1st gen was connected and loading things like a champ, but absolutely nothing on the new 2nd gen. I was crushed.



    My first hit on a google search brought me to this thread, and your post.



    Here is the really cool thing: I loaded the IP address you posted for google, and whoopee...it loaded the page. Then, magically, my wireless was working. No change to the router, nothing. I turned the touch off, then on again, and it was still working.



    So, I have gone from pleased with my ebay purchase, to crushed and miserable, to ecstatically relieved, all in the course of a couple of hours. And this great outcome is due entirely to your post.



    You rock.



    Flynike




  • Reply 7 of 7
    What flynike said. I had my iPod Touch 2G for just a week when it started having this problem, and no other fixes were working, and I was quite disgruntled. I made an appt at the local Apple Store for today and figured the device would be out of commission for a while. But my husband found your explanation overnight and followed your instructions, and whee! It works now!



    Thanks again. Apple doesn't recognize the problem -- someone should forward them this thread!





    Quote:
    Originally Posted by flynike View Post


    Andy--I can't thank you enough. I joined this forum just to tell you how great your advice was!



    I just got a 2nd gen on ebay, and it seemed to be working great. Then the wireless trial, and...



    I saw that damned "wireless connected" icon, yet nothing would load. My 1st gen was connected and loading things like a champ, but absolutely nothing on the new 2nd gen. I was crushed.



    My first hit on a google search brought me to this thread, and your post.



    Here is the really cool thing: I loaded the IP address you posted for google, and whoopee...it loaded the page. Then, magically, my wireless was working. No change to the router, nothing. I turned the touch off, then on again, and it was still working.



    So, I have gone from pleased with my ebay purchase, to crushed and miserable, to ecstatically relieved, all in the course of a couple of hours. And this great outcome is due entirely to your post.



    You rock.



    Flynike








Sign In or Register to comment.