Please Help - Highly Unusual AddressBook Behavior

in Mac Software edited January 2014
I'm having a really strange problem with Apple's address book that I was hoping somebody could give me a hand with.

For some reason, every time I open the address book app, no application window opens, though I do see the 'address book' app menu appear in the finder's menu bar. The only way I can get the address book application to appear is by going to the 'Window' menu and choosing the menu option 'Address Book'.

Doing so does cause the app's main window to appear, however the problem that occurs at this point is that it doesn't allow me to click anything on the window (meaning I cannot select any of my contacts because clicking doesn't highlight them or do anything).

In tinkering with it a bit, I've discovered that the only way I can actually select anything (and thereby even use the address book) is do the following:

-- Choose 'address book' from the 'window' menu, wait for the un-clickable window to appear, then drag the lower right-hand corner of the window to resize the apps main window... Doing so causes the address book window to appear all white (as if it has frozen and is about to force quit itself ~ though it's not frozen);

-- Then I press Cmd+W to close the white window;

-- Finally, I then if I go to the 'window' menu one more time and choose 'address book', it hides the white address book window from view, and selecting it a second time immediately afterwards, brings the address book window to the front again and I can now click on it and use it normally...

As I stated in my post I realize that this is a highly unusual phenomenon and I really don't expect anyone here have an answer for what the heck is going on!

I have done the following troubleshooting steps to try to fix the issue myself, and nothing has worked:

-- I've trashed the address book preference file

-- I've temporarily disabled MobileMe & Google Contacts Syncing (which are both normally enabled)

-- I've used Disk Utility repair permissions

-- I've used Cocktail to run a battery of maintenance techniques (such as emptying caches, running daily weekly and monthly cron scripts, cycling logs, etc...)

-- I have of course restarted several times,

-- And I've tried restoring an old exported 'Address Book Archive' file

Needless to say, nothing has fixed my problem!!

I would be beyond grateful if anyone could help me out with this issue, as I've run out of options here...

Any suggestions would be greatly appreciated... thanks for your help!
Sign In or Register to comment.