Messed up my permissions...

in Genius Bar edited January 2014 being stupid.

First of all, I've only had my MacBook Pro less than a week. And I just connected to a WLAN with lots of other Macs on it for the first time a couple of hours ago and got kinda freaked out by all the shared folders available. Even though there was probably nothing in them.

Anyway, so my intent was to lock my hard drive down so nobody else (but me of course) could get into it at all. Not even the public folders. So I went to my hard drive icon, did "Get Info," unlocked the permissions, and set "everyone" to "No Access." Well guess what? Now I can't change it back coz I can't unlock the lock. And some of the other system preferences that have the lock on them say "Authenticating..." and eventually hang when I click the lock (no password entry thing pops up) so I end up having to force quit them.

I'm attempting to run the Disk Utility from the hard drive but I'm on 8% battery as I write this and it still hasn't finished reading the permissions. I'll try again later, but meanwhile, I want to know if I'm doing the right thing or not? Or am I just royally intercoursed?

I'm rather panicky right now...


  • Reply 1 of 2
    bbwibbwi Posts: 812member
    Don't know the exact answer but here's my opinion...

    Why does battery life have anything to do with it? Boot off the cd and run Disk Utility to repair permissions
  • Reply 2 of 2
    Well, as I was writing that I didn't have anywhere to plug in...

    OK, so here's what's happened since then:

    After posting that, I put the computer to sleep so I could search for a power jack. I did, but the computer became completely unresponsive and wouldn't wake up even after a 50% charge.

    I took it home and tried to boot from the DVD and it wouldn't until I'd reset the power manager AND the parameter RAM (attempting to boot from the HDD resulted in some kind of infinite loop on the blue screen). Finally I got it booted from the DVD, ran the disk utility, and tried repairing the permissions. It immediately failed with the message "The underlying task reported failure on exit."

    Then I tried the Windows partition so maybe I could salvage anything that might be in there. Windows started just fine but all my files and folders are corrupted.

    Don't know if this is significant or not, but in Terminal the Macintosh HD volume had an l (locked) attribute on it after I changed that permission.

    Not knowing what else to do, I guess I'm about to reformat and reinstall OS X. I haven't been able to find anything that sounds even remotely like this on the internet. And the corrupted files make it seem like a lost cause to me anyway. At least there's not a huge amount of loss involved.

    Anyway, I still don't get how changing that permission could do all that though. I can understand it locking me out (theoretically, coz I'm "everybody" too) but not the boot failure, disk utility failure, and splat Windows files.

    Needless to say, I won't touch it with somebody else's ten foot pole next time...
Sign In or Register to comment.