Frozen app refuses to force-quit; prevents restart & log-out

Posted:
in macOS edited January 2014
Is there any way to go about dealing with an application that has frozen (or results in the spinning of the 'beachball of death')...and then to top things off, decides to prevent you from force-quitting it as well!! Not being able to force-quit a stuck App is a major problem, because it means that I can then not log-out, restart or shutdown my computer...inevitably, my only option is to hold down the power button on my machine to force-shutdown!



I've tried everything I can think of...
  • I've force-quit by using Cmd+Opt+Esc;

  • I've tried force-quitting by Opt+Right-Clicking and choosing Force-Quit from the contextual menu;

  • I've tried quitting and force-quitting from the activity monitor;

  • I've tried force-quitting the Finder (even though it's not the Finder that has locked up

  • I've tried using the terminal to run "killall Dock" (I know this is a stretch, but it's gotten me out of sticky situations in the past...)

  • I've even tried using the 'Force-Restart' script that's included in the 'extra scripts' plugin for QuickSilver

As I originally said, when this happens to me, it usually results in my having to force-shutdown my computer, which is definitely something I would rather avoid completely for the sake of my internal/external HD's, and the data on them...



Any suggestions as far as alternative steps I might want to consider trying before using the last resort of holding down the frickin' power button would be greatly appreciated...



Thanks!

Comments

  • Reply 1 of 2
    MarvinMarvin Posts: 14,195moderator
    What app is it that is frozen? If it's a disk utility or some other app that deals with hardware, the OS won't allow you to force-quit in many cases.



    You can try using the terminal to do a force kill (sounds like a Star Wars move). You would go to the activity monitor and check the number at the left of the app - called the process id (pid). In the terminal, type:



    sudo kill -9 <pid>



    So if the pid was 13636, the command would be



    sudo kill -9 13636



    It will ask for your password.
  • Reply 2 of 2
    Thanks so much for the tip...I'll give it a shot the next time I run into this situation...I appreciate your input!
Sign In or Register to comment.