Finder not launching - HELP!!!

in Genius Bar edited January 2014
I logged into my Intel iMac this morning and the Finder is not launching. There is no tool bar on top, no hard disk image or iDisk image, nothing on the desktop. The dock does appear and I can open a few applications (like Safari, which I am using now), and the tool bar then appears, but without wireless, date/time, or any other icons except for Spotlight. But when I click on the finder nothing happens. I opened system preferences but tried to close it and the window closed, but the application won't close. it won't Force Quit either. Right click on my mouse isn't working, but will if I use the keyboard

I don't know if this is related or not, but a few days ago, Time Machine started saying it could not sync anymore. I looked at the preferences menu but didn't change anything. Interestingly, I can't open Time Machine right now. A Restart did not fix the problem. I am incapacitated right now, any help would be appreciated!


  • Reply 1 of 1
    Tried booting holding the SHIFT key? Any help?

    try installing & running Onyx, it's free.. The app will do a SMART test & verify the hard disk isn't having file system issues. Run EVERYTHING from the Maintainence tab. Restart the computer.

    You didn't say 10.4 or 10.5, so make sure you download the right one!

    Otherwise, Archive & install.
Sign In or Register to comment.