Boot Image Intel

in Genius Bar edited January 2014
I'm having problems trying to put a particular image into boot.efi on an intel mac, using the original .efi file from my installation DVDs (I got a firmware update a few years ago, and that messes up a lot for modding purposes).

Ok, if you don't know what I'm talking about, please read this and this. For the purposes of this thread, I will assume that you at least have browsed through these, or do know what I'm talking about (btw, those two are the only sources on the web I've found for a step-by-step process of doing what BootXChanger does automatically, so if you know any others, please let me know).

Anyway, after making the image I wanted, I converted the indexed .png into a .map, and deleted the first 6 bytes (I only had 2 colors in the image), ending up with my uncompressed .raw file (I tried to insert my own CLUT, but when I took the image back out again, there was an "unexpected end of image" error in ImageMagick, so I just used the table already in boot.efi. The colours for the background and the main foreground were at $01 and $50, respectively). Using a rl encoder I wrote in javascript, I compressed the .raw file to a size of 3,200 bytes. Although it's not supposed to be larger than 1,376, you supposedly can change the block count size, so that shouldn't have been a problem (this, by the way, is why complex images don't work in BootXChanger). When I boot up using bless, though (yes, I did try with the unmodified .efi first, and it worked), it doesn't work. What's strange about it, is that there's no error icon at all, like other times when it didn't work (the folder with a question mark). It just boots up the white(ish) screen, and hangs, no messages, no actions, nothing. I tried checking if the BootX file has a reference to how big the .efi file is, but there's no instance of either $00020C9E (the original .efi size) or $9E0C0200 (little endian format) anywhere in BootX.

If anyone has even the slightest clue or idea of something to try, please tell me.
Sign In or Register to comment.