Can't rip cd

in iPod + iTunes + AppleTV edited January 2014
Just got In Rainbows and I can't rip it.

Stick it into the cd drive and it either barfs on it or swallows it but doesn't recognize it (doesn't show up in finder or source pane in iTunes).

Anyone know what's going on?


  • Reply 1 of 2
    backtomacbacktomac Posts: 4,579member
    Never mind.

    Finally recognized and ripped.

    Not a good sign. I'm wondering if this is a sign that my optical drive is dying.
  • Reply 2 of 2
    Very quickly, while you still can, stick one of those lens cleaning discs in there.

    Same thing happened to me. First I couldn't rip CDRs. Then it was getting pickier and pickier with media. Then finally, when I tried installing Leopard, I found out that it couldn't read any discs whatsoever.

    Reading the advice forums, I was about to try cracking open the MacBook to get to the optical drive and clean it manually with a swab and some alcohol. But then I read about someone who used a cleaning disc, and that worked... and others agreed with the method.

    So that's what I did. And it worked.
Sign In or Register to comment.