10.2.3 and 10.2.4 problems w/windows shares? (-36)

Posted:
in macOS edited January 2014
i had a few machines that were set up to share via SMB. however, since updating to 10.2.3 and/or 10.2.4 this no longer works.



the apple tech support docs say it means



[quote] There are many reasons why the connection may be refused by the shared Windows computer.



First, make sure that the share point you are trying to connect to is set up correctly and that other users can log in to the computer.



You should also verify that the user account you are using is set up properly. When you log in to the computer, make sure you are entering your user name and (case-sensitive) password correctly.



If you are connecting to Windows XP, make sure that the Internet Connection Firewall settings are not interfering with your connection. SMB uses ports 137, 138 and 139. These ports should be open on the Windows XP computer.



Information about products not manufactured by Apple is provided for information purposes only, and does not constitute Apple's recommendation or endorsement. Please contact the vendor for additional information.



<hr></blockquote>



it doesn't really help me that much. anyone else run into this problem and know how to solve it?



[ 02-26-2003: Message edited by: alcimedes ]</p>

Comments

  • Reply 1 of 14
    overhopeoverhope Posts: 1,123member
    Probably not a help to you, but I've got SMB running to a shared drive on my Windoze 95 machine with absolutely no problems under 10.2.4: it even pops up in the "Connect to Server" window...
  • Reply 2 of 14
    I've had one experience with this that might help. When I open the connect to server dialog our main server pops up in the window with its IP address, say 10.0.1.10. If I use this - smb://10.0.1.10 - I always get a -36 error. If on the other hand I put in the machine name, say Goofy, i.e. smb://Goofy, all works fine. Apparently the Connect to Server picks up the IP and not the Name in this case and the system reject connections directly to its IP. BTW the IP is correct.



    Hope this helps.
  • Reply 3 of 14
    alcimedesalcimedes Posts: 5,486member
    hmm, it doesn't work, even with the name as opposed to the IP. turns out this is happening campus wide as well. so have any of you gotten windows shares to work with OSX 10.2.3 or later?
  • Reply 4 of 14
    farmer2farmer2 Posts: 21member
    [quote]Originally posted by alcimedes:

    <strong>hmm, it doesn't work, even with the name as opposed to the IP. turns out this is happening campus wide as well. so have any of you gotten windows shares to work with OSX 10.2.3 or later?</strong><hr></blockquote>





    I have heard of a username password bug that can pop up in upgrades. Try changing the password (on the pc) to something different then change it back to what you had. Then try logging in again. If this still doesn't work log off the mac log back into it and then try accessing the share on the pc.

    Good luck
  • Reply 5 of 14
    dstranathandstranathan Posts: 1,715member
    Is Password Server configured properly?
  • Reply 6 of 14
    dstranathandstranathan Posts: 1,715member
    (double post, sorry)



    [ 03-02-2003: Message edited by: dstranathan ]</p>
  • Reply 7 of 14
    alcimedesalcimedes Posts: 5,486member
    i'll give the password change a try, see if that helps
  • Reply 8 of 14
    gizzmonicgizzmonic Posts: 511member
    I'm having major SMB problems as well. Sometimes I can connect, sometimes I can't, I can never transfer files, it's really slow, etc...



    Used to work fine in 10.2.1. I dunno what happened.



    Also, WTF is up with the "-36" errors? Apple, give us some friggin useful dialog boxes, this ain't Windows!
  • Reply 9 of 14
    alcimedesalcimedes Posts: 5,486member
    sharity worked just fine for those who also might have this problem.



    thanks for the program idea!
  • Reply 10 of 14
    skip sharity its not worth it if you have jag



    The -36 error can pop up and its usually a keychain problem. go to the keychain app (in utils?) and delete all the entries for the share you are having problems with. Sometimes a corrupted keychain entry will prevent you from even being prompted for a password.



    If you want to see your windows machines show up in the 'connect to...' finder dialog then do this (abridged from apple support)



    1. open Directory Access (/applications/utilities/)

    2. click the lock to get admin access

    3. Select SMB from the services list

    4. Click configure

    5. Select the name of the workgroup (if it appears) or type in the workgroup name your windows network is using

    6. Click OK

    7. Click Apply

    8. Quit Directory Access.



    This works great on my network with a couple of win2000 boxes and a win98 one. I can see all my windows boxes from my mac AND vice versa!



    It really is sweet when you get it going. Hopefully 10.3 will have a little more centralized network management.



    You can also make sure that windows filesharing is on in the Sharing control panel. Sometimes that gets flipped off. Check the firewall setting on Sharing as well to make sure you are not blocking the SMB port.



    hope this helps
  • Reply 11 of 14
    alcimedesalcimedes Posts: 5,486member
    excellent. i'll look into that.



    edit:



    still won't connect, and it wasn't in the keychain (as i've never connected to it from this machine) although now the workgroup shows up, so that's a step forward.



    [ 03-06-2003: Message edited by: alcimedes ]</p>
  • Reply 12 of 14
    alcimedesalcimedes Posts: 5,486member
    Solved, but not necessarily fixed...



    [quote]xxxx xxxxxx wrote:

    &gt;

    &gt; Problem:

    &gt;

    &gt; Since updating to 10.2.3 or maybe just since 10.2.4 on (2)

    &gt; Powerbooks G3 & G4 & a QuickSilver G4, I can no longer attach to a

    &gt; Windows-2000sp3 Server w/ all the current patches (which as not

    &gt; changed in a few weeks) via SMB, but Appletalk works (since I am

    &gt; runnig Appletalk on the server).

    :

    :



    This turned out to be quite an interesting little problem. Andy was

    able to send a tcpdump capture to me, and I've figured out what's going

    wrong and sent a message to my friend at Apple. Here are the details:



    - This wasn't an authentication problem, because the Macintoshes were

    not even getting to the authentication step. An NBT connection

    was being used (that's NetBIOS over TCP on port 139). Before the SMB

    protocol can start up, the NBT session must be established. It was

    the NBT Session Request that was failing.



    - Looking at the Windows2Ksp3 system that xxxx is running, I found

    that some application is registering a malformed NetBIOS name. The

    malformed name is being registered as a "unique" name and has a

    suffix byte value of &lt;20&gt; (a space).



    - Andy was attempting to connect to the server using the DNS name of

    the server, rather than the server's machine name.



    ...this is where it all gets interesting.



    - The SMB Server Service name is always registered as machine-name&lt;20&gt;.

    The NetBIOS machine name is typically the same as the DNS hostname

    (unqualified). That's not a hard-and-fast rule (and, in fact, it's

    a bit of a kludge) but it is the way Microsoft likes to have things

    done. So, if my machine is ruby.nts.umn.edu then the NetBIOS name

    for the SMB Server Service would be RUBY&lt;20&gt; (where &lt;20&gt; is the

    hex value of the 16th byte of the name--called the 'suffix' byte).



    - Windows requires a "correct" NetBIOS name in the NBT Session Request

    message but the name entered on the Macintosh was a DNS name which,

    as I suggested, does not necessarily match up with the NetBIOS

    machine name.



    - So... The SMB client software on the Macintosh was trying to find a

    correct NetBIOS name to make the connection. There are a lot of

    ways to do this. Some good, some bad. One way is to simply try

    the first label of the DNS name. Another is to send a query to the

    server and *ask* for its name.



    - The Macintosh software was sending the query to the server. That's

    a good solution. Unfortunately, as mentioned above, some service on

    the server is registering a malformed unique name with a &lt;20&gt; suffix.

    The Macintosh was guessing incorrectly that the malformed name was

    the SMB Server Service name.



    - The real problem, though, is that the Macintosh was giving up after

    receiving the error from the server. It should have tried the other

    &lt;20&gt; name and/or the first label of the DNS name (which would have

    been the same as the other &lt;20&gt; name) and/or the generic SMB Server

    Service name "*SMBSERVER&lt;20&gt;".



    Summary:



    - The first bug is that some piece of software on the W2K server is

    incorrectly registering a &lt;20&gt; name. (The name is also mixed-case,

    which is wrong as well.)



    - The second problem is that the Macintosh's SMB software is giving up

    too easily.



    Workarounds:



    - Use the NetBIOS name instead of the DNS name. That should fix it.



    - In the latest SMB URL Internet Draft, we added the ability to specify

    the destination NetBIOS name (the "Called Name"). I don't know if

    Apple's implementation supports this. They may, or they may be

    waiting until the draft gets a little more stable.<hr></blockquote>



    well, this was one solution to the problem. not sure if this is what other people have run into though.
  • Reply 13 of 14
    tkntkn Posts: 224member
    So how does all this netbios stuff work if I wanted to try this?
  • Reply 14 of 14
    stoostoo Posts: 1,490member
    To enable NetBIOS on a PC (Windows 2000, probably XP as well)<ol type="1">[*]go to Network and Dial up Connections control panel and open the Local Area Connection.[*]scroll down the list of services protocols used on the LAN connection and select Internet Protocol (TCP/IP). Click Properties.[*]In the Advanced section the TCP/IP properties, look for an option to enable/disable NetBIOS: turn it on. You don't have to do anything on the Mac.[/list=a]



    Typing the name of the SMB server rather than the IP address worked for me. Seems to be about as fast as FTPing files off the PC using IIS (Window's webserver): Airport Extreme at 54Mbps? I'll be lucky. <img src="graemlins/lol.gif" border="0" alt="[Laughing]" />
Sign In or Register to comment.