Suddenly unable to connect to wireless network...exhausted all fixes

in Genius Bar edited January 2014
I?ve got an odd problem with my two-week old MacBook Pro and its connection to my wireless network. I?ve done what I think is pretty exhaustive troubleshooting, but remain baffled. Here?s the story.

This morning I connected to my wireless network (DSL 2WIRE modem/router) with no problem. This afternoon I returned and Airport refused to connect, giving me the error message, ?Airport is unable to connect to the wireless network?? The network shows up as being available, but when I attempt to connect, it wont. (I didn?t make any changes or install any programs this morning).

Here?s what I?ve done:

[1] Restarted the router

[2] Repaired permissions

[3] Deleted the network?s entry in Keychain Access

[4] Re-entered my WEP code (assuring it is in correctly; I?ve tried both with the ?$? and without)

[5] Used interface robustness and without.

[6] Attempted to join the network from the System Preferences>Network.Airport route.

[7] Created a new account and tried connecting.

Other tidbits of information:

[1] Another MacBook in the house connects to the network with no problem.

[2] My MacBook can connect to another (unsecured) network that I can ?see? in my house.

So, it would seem my Airport card is working okay.

Any ideas??


  • Reply 1 of 6
    sunilramansunilraman Posts: 8,133member
    Turn off WEP/WPA whatever type of encryption and check if you can connect...
  • Reply 2 of 6
    Originally Posted by sunilraman View Post

    Turn off WEP/WPA whatever type of encryption and check if you can connect...

    I tried that and now I can connect. But, since I share files with other computers on my home network, I'm not comfortable with this being the "solution". Is there a next step?

    Thanks for your help!
  • Reply 3 of 6
    For anyone interested, I seemed to have solved my problem. Don't know why it works, but here's what I did:

    [1] Turned off the WEP security in the router

    ====>computer could connect

    [2] Turned it back on

    ====>could not connect (same as original error)

    [3] changed the WEP code to something other than the factory default code.

    Success! Computer connects.

    So, even though I had supposedly cleared the Mac's WEP cache (or whatever it is called via the KeyChain Access).

    Anyway, all is happy now.
  • Reply 4 of 6
    sdw2001sdw2001 Posts: 17,035member
    Ive been having a lot of problems with disconnects, inability to reconnect after sleep, having to rejoin constantly, restart the station, etc.

    After reading this thread I tried messing with my security settings. I eliminated all wireless security and it was like magic. Then I went from WPA2 to WEP 128 bit and my problem so far continues to be fixed. My router starts right back up now (sometimes I could not get the AExpress router's light to go green) and my computer joins it faster. The speed seems better too.

    It looks like we've ID'd a serious problem here. For you it was WEP, for me WPA2, but it's pretty clear that the wireless security is causing all kinds of Airport screw ups.
  • Reply 5 of 6
    Finally, the problem is gone. It took me a while to figure out what WEP and Wpa meant, but I made it. Swithcing WEP to WPA solved my 'connectin-to-the-Internet' problem, and I'm hoping the network will remain on.

    For those of you who use 2WIRE router, go to, then go to HOME NETWORK->wireless settings->wireless security->change the authentication from WEP to WAP-PSK (i also changed my channel to 11-2.462MHz). Click on custom encrypton key and type your password (w/out $).SAVE.

    Hope that helped!

    P.S. I just want to point out that Apple's customer service is awesome! Among other things, I have found out that Apple's local stores offer various classes for the products.
  • Reply 6 of 6
    nofeernofeer Posts: 2,422member
    did you try wpa rather than wpa2?? i used this for my new linksys 300n and it worked great, two macbooks connected no problem, also wpa is stronger than wep, but you have to get those hexidecimal keys just right. i used wep key without the $ on all my units no problem/

    BUT my imac g3 won't connect with wpa only wep

    maybe i should start a new thread with this
Sign In or Register to comment.