Leopard Permission Weirdness

in Genius Bar edited January 2014
Here's the deal.

I can no longer change the tags on anything I import into iTunes. Can't modify album artwork or any metadata.

So, I took a quick squizz at the permissions for said files: opened the info window, saw the accounts 'unknown' and 'everybody' (which includes the admin account) could 'read only'.

But I can't make changes to read and write, or to anything, or get rid of 'everybody' by pressing the '-' button to remove said useless account. First Finder crashed. Next time, and every other time, it just ignored me.

I've scoured teh intarnets, done some terminal jiggerpokery (chmod -R -a# 0 file_or_folder_name was popular about half an hour ago), read the Apple discussions for other people's permission woes.

But still: I can't change the metadata on anything I import into iTunes and I can't change the permissions on any of these files in order to make said changes.

Anyone seen this / fixed this / going to help me / be nice / want an ice-cream?


  • Reply 1 of 5

    I think this might be a common problem. The cure is here:


    And here it is.


    Fire up Terminal (/Applications/Utilities/Terminal), and change the directory to the main "Users" folder. At the prompt, type this:

    cd /Users

    Now, to reset the "group" permissions for all files that match your user, type the following, replacing "yourusername" with the short version of your username. Not sure what your short username is? Just check what your user folder is called.

    sudo chown -R yourusername:staff yourusername

  • Reply 2 of 5
    Hasn?t fixed it.

    Not for new files. I can change the permissions now, but I'm still not lord and master of my own data.

    If I convert a file from .aif to .aac or import anything new, I have to alter the permissions to ?read and write?, file-by-file, in order to change the album art or any of the other tags.

    Anyone had this? Anyone braved the internet to find a cure or has the terminal skills to stop this happening?
  • Reply 3 of 5
    where is your music stored? if it is under your home directory / music, apart from the chown command, do a chmod -R 744 yourusername from the /Users directory. You don't need a sudo to do this if you did the chown command properly.


    alternatively, click on your home folder in Finder and do a Get Info. You will be able to change the permissions in there. Set it to readwrite for yourself, read for everyone and staff and make sure you apply the right permissions to the enclosed items via the "wheel" icon in there.


    Also, type the command "id" in terminal and make sure your user group is "staff". if that is fubared, go to system preferences and "users and groups" and right click on your portrait after authentication and you will get the advanced options menu. You can change your group id in there. the staff group id is usually 20. don't touch the UUID in there or the user account will lose access to the system.
  • Reply 4 of 5
    Thanks, talksense.

    That's all the obvious stuff I should have thought to do in the first place! I had no idea those advanced preferences in Accounts even existed.

    My music's where it oughta be. The problem was that I couldn't change the permissions globally because the info window wouldn't let me make changes at all: it kept reverting to 'Write Only' the second I closed it.

    The problem seems to be more widespread than my music folder, though, which is worrying. \ I think I'm going to reinstall Leopard just to be safe and not do any more system wide-ish jiggery-pokery.

    It's a curious problem, though, which would be next to impossible to fix if you weren't at least primitive dork level.
  • Reply 5 of 5
    It is a curious problem though. Leopard's permissions are much better than the previous versions when they work. If you are running third party applications that perform system optimization, make sure you only run those that are built for Leopard.
Sign In or Register to comment.