Safari browser font now super bold

Posted:
in Mac Software edited January 2014
Since I installed Snow Leopard the bold font in Safari is now a rather ugly extra bold font. The rest of the type is still ok.

Comments

  • Reply 1 of 10
    bbwibbwi Posts: 812member
    Yep, this is by design unfortunately.



    Here's how to revert it



    In Snow Leopard, you can only choose between Automatic and Standard CRT. Since few people use CRTs these days, most users now have only one option: Automatic. The problem with the Automatic option is that OS X incorrectly detects many third party LCD monitors as CRTs, and consequently, disables LCD font smoothing.



    You can force OS X to use LCD font smoothing on all displays with this Terminal command:

    defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

    The number 2 here corresponds to Medium - Best for Flat Panel. You may also use 1 for light smoothing, and 3 for strong smoothing, as per the original OS X font smoothing options.
  • Reply 2 of 10
    Yet another 'flaw' in Snow Leopard! To add to the list of, at least, dozens, and perhaps even hundreds of other 'flaws', shortcomings, and glitches causing headaches, aggravation, and considerable productivity loss for thousands of loyal users ...



    Snow Leopard was clearly not yet ready for release! Shame on Apple!
  • Reply 3 of 10
    thanks for the tip but that hasn't helped. It appears the actual font is different - extra bold or black.
  • Reply 4 of 10
    irelandireland Posts: 17,684member
    Post a screenshot please.
  • Reply 6 of 10
    irelandireland Posts: 17,684member
    I am definitely not seeing that on my SL Macs.
  • Reply 7 of 10
    bbwibbwi Posts: 812member
    just go into safari preferences and choose a smaller font
  • Reply 8 of 10
    irelandireland Posts: 17,684member
    Quote:
    Originally Posted by bbwi View Post


    just go into safari preferences and choose a smaller font



    That's not the issue. Looks like a bug to me. Try repair permissions and restart your Mac.
  • Reply 9 of 10
    bbwibbwi Posts: 812member
    Quote:
    Originally Posted by Ireland View Post


    That's not the issue. Looks like a bug to me. Try repair permissions and restart your Mac.



    How does this at all resemble a permissions problem?



    If you're using a Macbook then maybe you zoomed in by accident. Are you using a Macbook?
  • Reply 10 of 10
    irelandireland Posts: 17,684member
    Quote:
    Originally Posted by bbwi View Post


    How does this at all resemble a permissions problem?



    If you're using a Macbook then maybe you zoomed in by accident. Are you using a Macbook?



    Believe it or not this sometimes helps with this sort of issue. Resemble? It's not about resembling, it's about going through the motions. It's certainly not zoomed in, that's for damn sure. You can argue all day, but trail and error can't be argued with.
Sign In or Register to comment.