slow internet startup after sleep

Posted:
in Genius Bar edited January 2014
I'm not sure if this is a problem or if its just the way it is in OS X, but everytime I wake the computer from sleep and try to get on the internet it always takes about thirty seconds. Everything else works within about 5 seconds of waking except the internet connection. Is this normal? Thanks in advance.



Powerbook 667mhz DVI, 512mb

Cable modem

Comments

  • Reply 1 of 3
    neutrino23neutrino23 Posts: 1,554member
    I've noticed the same thing. It seems to be renegotiating the connection. I've found in OW that after sleep if I click a link, wait a few seconds then click stop then click another link it will connect more quickly.



    I also noticed that when I recently booted into OS 9 and used iCab that it really was fast. Maybe there is something at a low level in the OS that is not real fast about connecting to links in OS X. Let's see how 10.2 does.
  • Reply 2 of 3
    Macs tend to be rather slow on the net as is.. though I don't think that is your problem.



    When I put my book to sleep, it loses all connections with everthing else.. all periferals power-down (I always forget to eject the ipod!) and it loses its connection to any local or remote network. Most likely you also have your settings on DHCP to find your address.. if you set your address (is that possible for you? depends on if you are dial up, dsl/cable, using a router etc..) to Static (IE you choose your address). That usually quickens the pace.



    Another trick, (great for start-up as well) is turning off all modems, networks, appletalk etc.. leaving only your one base network method always on (ethernet I suppose). That way, fewer things need to be searched for, and addressed/logged/notified.



    I think in the end though, that you will have to wait at least a bit (say 10 seconds or so) for the net connection to appear.
  • Reply 3 of 3
    vikingviking Posts: 127member
    Thanks for the info.

    I actually figured out what was going on? Under my active ports prefs, the ethernet port was configured last and the airport and 56K modem ports were first (I don't use either.) I turned those off and put the ethernet port first and now the wait time is like 5 seconds. Much more tolerable.



    PB G4 667MHZ DVI 512mb OS X
Sign In or Register to comment.