akitio node, gtx 970

Posted:
in Current Mac Hardware
I need help, Im trying to get my GTX 970 in an akitio node eGPU to run with my 2017 MacBook bro with High Sierra 10.13.3 is this possible?

Comments

  • Reply 1 of 4
    tallest skiltallest skil Posts: 43,399member
    9to5 has a simple setup guide, and then there are troubleshooting forums for eGPUs for more specific information. Have at ‘er!
  • Reply 2 of 4
    Mike WuertheleMike Wuerthele Posts: 4,414administrator
    The Nvidia drivers aren't great, right now, and Apple isn't exactly helping. For your situation, the troubleshooting forums are far better than 9to5's guide. 
  • Reply 3 of 4
    The Nvidia drivers aren't great, right now, and Apple isn't exactly helping. For your situation, the troubleshooting forums are far better than 9to5's guide. 
    Well I have downloaded the latest drivers from Nvidia and when I plug in my akitio node it doesn't detect the 970 for some reason. not sure if im missing something.
  • Reply 4 of 4
    Mike WuertheleMike Wuerthele Posts: 4,414administrator
    dirty-max said:
    The Nvidia drivers aren't great, right now, and Apple isn't exactly helping. For your situation, the troubleshooting forums are far better than 9to5's guide. 
    Well I have downloaded the latest drivers from Nvidia and when I plug in my akitio node it doesn't detect the 970 for some reason. not sure if im missing something.
    Yeah, like I said, the drivers aren't great. The troubleshooting forums have a solution for you.
Sign In or Register to comment.