How to fix Universal Clipboard problems on macOS

Posted:
in macOS edited April 9

While generally quite reliable, Apple's Universal Clipboard can sometimes stop working for no apparent reason. Here's how to fix it and get back your cross-device productivity.

Universal Clipboard makes copying text between devices easy.
Universal Clipboard makes copying text between devices easy.



Universal Clipboard is Apple's cross-platform feature that allows users to quickly transfer document elements and files between devices. Part of the Continuity system that enables productivity across the Apple ecosystem, it has become an extremely well-used and indispensable feature of Apple's operating systems.

Much like how copy and paste works at a system level to shift files, text, video, or images between documents or storage folders, Universal Clipboard is the same thing, but across multiple devices. It's possible to copy text from one item, like a Mac, and to paste that same data to Messages running on an iPhone.

This opens up your hardware to some extremely useful abilities. For example, you could copy a photo sent to you in Messages on an iPhone and paste it directly into a document you're editing on a Mac.

After a drawing session on an iPad, you could copy and paste the image into another application on your iPhone. The same with files, so you can quickly attach a file stored on a Mac to an email you've written on an iPad.

It's not just limited to Apple's well-established hardware types. Owners of the Apple Vision Pro can use exactly the same system to handle data and files from their headset.

However, while it is generally reliable, sometimes Universal Clipboard doesn't work, and sometimes ceases working altogether.

Here are some of the things you can do to get Universal Clipboard back in order.

How to fix Universal Clipboard -- Initial Checks



First, make sure that Universal Clipboard has everything set up so that it works normally.

For every device that you want Universal Clipboard to work on, you need to make sure they're all signed in with the same Apple ID and can access iCloud.

Checking Handoff is enabled on an iPad
Checking Handoff is enabled on an iPad



You also have to ensure that the devices all have Bluetooth enabled and have Wi-Fi enabled. Ideally they should be on the same Wi-FI network, and to be within close proximity to each other.

Handoff also needs to be turned on for every device. It is turned on by default, but it can be disabled.

How to check Handoff is enabled on Apple devices

  1. On an iPhone, iPad or Mac, go to Settings then General followed by AirPlay & Handoff, then ensure Handoff is toggled on.

  2. On a Mac, select the Apple logo in the Menu Bar then select System Settings followed by AirDrop & Handoff. Turn the toggle on for Allow Handoff between this Mac and your iCloud devices.

  3. On an Apple Vision Pro, select Settings then General, then Handoff. Turn on Handoff.



If it's not working and it is still enabled, you could try turning off these toggles, then turning it back on again.

Checking Handoff is enabled in macOS
Checking Handoff is enabled in macOS



After checking all of your devices have Handoff enabled, another thing to do is to make a change at the command line on your Mac. This is performed using the Terminal.

How to turn Handoff on and off via Terminal on macOS

  1. Open the Terminal. The quickest way is to press Command-Space then type in Terminal into the search bar, followed by Enter. It can also be opened by opening the Applications folder then Utilities, followed by Terminal.

  2. In the Terminal, enter the line defaults delete ~/Library/Preferences/com.apple.coreservices.useractivityd.plist ClipboardSharingEnabled followed by Enter.

  3. In the Terminal, enter the line defaults write ~/Library/Preferences/com.apple.coreservices.useractivityd.plist ClipboardSharingEnabled 1 followed by Enter.

  4. Close Terminal


Read on AppleInsider

Comments

  • Reply 1 of 7
    omasouomasou Posts: 592member
    I had been having this issue on MacOS for probably over a year. Even a call to Apple didn't resolve the issue.

    I read about the terminal fix a few months back and been working since.
  • Reply 2 of 7
    sunman42sunman42 Posts: 273member
    I’m probably in an incredible minority now that laptops have effectively replaced desktops, but I find the WiFi requirement for Handoff features to be unnecessary. Why can’t these features work for any and all devices on the same subnet, regardless of physical access layer?
    appleinsideruser
  • Reply 3 of 7
    rivertriprivertrip Posts: 143member
    Fix Handoff not working when it is enabled by enabling it?
    edited April 9
  • Reply 4 of 7
    …after previously disabling it.
  • Reply 5 of 7
    derekwderekw Posts: 3member
    Amazing! I've been trying to solve this problem for months. The Terminal trick worked!
  • Reply 6 of 7
    pmaccapmacca Posts: 1member
    terminal fix didn't work for me. message is...

    "Domain (/Users/username/Library/Preferences/com.apple.coreservices.useractivityd.plist) not found."

    Thoughts?

    I tried searching macinstosh hd for com.apple.coreservices and no luck.

    PS: I have an intel 2018 MBP

    tia


  • Reply 7 of 7
    So try step 3 which will create the file. 

    Then do step 2 & 3. Might work…
Sign In or Register to comment.