can't install Safari!

in Genius Bar edited January 2014
I recently had a big time system crash, so bad that every time I restarted the finder would immediately and continually quit until I was left with nothing on the screen. I archived and installed back to 10.3.2 and things seemed back to normal until I tried to launch Safari, which hung.

I've trashed the Prefs and downloaded the installer from Apple's site, but now the installer hangs when launched and I have to force quit out. I hadn't had trouble with Safari in the 6 months before.

dual 1.42 G4, 1.5gb ram, OS 10.3.2


  • Reply 1 of 2
    What version of Safari are you trying to reinstall?

    You need v1.2 for Panther and unless something has changed the one on apple website is only v1.0.2.

    You will need to reinstall of the OS CD's.

    Look for a program called Pacifist v1.6 as this allows you to install the necessary installer, and not perform the whole thing.

    If you search google for Safari Pacifist and Install I would guess you would get more info.

    Hope this helps

    EDIT: Had a look on the apple website and it looks like they are now making it available (as from 2 Feb).

    The above Safari version details is still relevant
  • Reply 2 of 2
    Have you tried all the standard fixes from the FAQ thread?

    * clearing the cache

    * repairing permissions

    * repairing the disk
Sign In or Register to comment.