major iPod problem

in Genius Bar edited January 2014
ok, i have a 15 Gb iPod on my G3 iMac, i bought it about a year ago (warranty just ran out) and i have been using it at school. everytime i plugged it in at school, it would go through that directory check, or whatever it is when it has the magnifying glass on it. and one time, after the check, it ave me the broken folder. so, i figured, no big deal, i'll just reformat it and restore it, right? i get home, and it says "you have inserted an unrecognizable disk" and gave me the options to eject, initialize, or ignore. i chose "initialize". it opens up disk utility, and it says that it is a 38 GB FW disk! wtf?! so, i try to format it, and i leave it going. i go back 2 hours later, and it still says "preparing the disk". so, i unplug it, and put it into my dads G4. it says it's a 13.9 GB FW disk, so that is ok. i let it initialize, i come back an hour later, and it is still "preparing the disk". what is this!!!!!!!!??? i need to get this working soon. can anyone give me any advice? please help me!


  • Reply 1 of 4
    lemonlemon Posts: 29member
    I had a similar problem with a 5gig iPod. OS 9 was able to fix it. I'm not sure if your iPod would work with OS 9 thought. And do you have to use disk utility to format it? I thought the iPod utility gives you the option to do it too. Althought they probably use the same mechanism to do it. It might be worth a shot. Well, good luck.
  • Reply 2 of 4
    ebbyebby Posts: 3,110member
    The iPod utility will reformat the drive if you choose restore. However, lots and lots of people are having problems either from the last iPod update or iTunes. I also have this problem, and it is only getting worse. (I had to reformat yesterday because all my music disappeared) Make sure you always have a good backup.
  • Reply 3 of 4
    mattjohndrowmattjohndrow Posts: 1,618member
    ok, i plugged it into my moms g3 iBook, booted up in 9 and formatted it in 9. i went into os x on her machine and it worked fine. i updated the iPod software on her machine. but! i plug it into my G3 iMac and it gives me the same message about how i can either initialize , ignore, or eject the disk. wtf?!!!!!!! so, i boot up in 9 on my iMac, and initialize it in 9 but it says it's a 45 GB iPod, so, that didn't work too well, and i boot into X and it still doesn't recognize it! AHHH! and i leave for maine tomorrow, and i don't know what i'm gonna do! help
  • Reply 4 of 4
    ebbyebby Posts: 3,110member
    If you format your iPod using disk utility, it will only work as a external drive. You need to use the iPod update's restore feature to load the iPod software. As for the strange disk size... You got me!
Sign In or Register to comment.