Internet Problems

in Genius Bar edited January 2014
Well, from my house and dorm, I'm able to access the internet perfectly. AIM will connect, I can visit any website (albeit I have to refresh a few to get them to load in Safari) and everything is just peachy.

But at some friends apartment, I hook my ibook G4 Mac OS X.3.6 up to their LinkSys BEFSR41 router and not only can I not play World of Warcraft (which is why I'm over there), but also I can't access some internet sites. AIM still connects, and I can visit Google and some other sites, but among those that just refuse to load are this one (appleinsider), Yahoo!,, and I can even do Google searches, but the result websites usually aren't able to load (some of them are, such as the Mac OS Hints forum).

The firewall is disabled, and I'm not sure why only some sites will load, and nothing else. I even managed to ping/traceroute Yahoo! Please help!


  • Reply 1 of 5
    The DNS servers are in the router, but I've even tried copying them from the router settings and adding them into my own internet preferences, without luck.
  • Reply 2 of 5
    Just to clarify, there were several other Windows computers hooked up to the router which worked perfectly, using DHCP from the router.
  • Reply 3 of 5
    Well, it is definately a DNS problem. You may try rebooting after setting up your machine to use their WiFi DHCP connection too see of this helps (It shouldn't, but it may).

    Open and try "dig" where is a domain you can't seem to connect to.

    Paste some results in here.
  • Reply 4 of 5
    I'm back at the dorm, but I did manage to get everything working when I connected directly to the cable modem, without going through the router. I'm heading back over to the apartment in a few minutes and will definately try that.
Sign In or Register to comment.