PM 1.8 single (late 2004) freeze issue

in Current Mac Hardware edited January 2014
We now know that 10.4.3 has not resolved the issue with the G5 single 1.8MHz (late 2004) model.

Some people have raised a big enough stink so that Apple has replaced their systems with new dual CPU models, but this apparently requires bringing it in for repair twice and doggedly pestering AppleCare and Customer Service to the breaking point. Most of us, clearly, would rather not go through that rigmarole.

There have been rumors of a firmware update floating around for months now, but nothing definite from Apple. Lots of warranties are getting ready to expire.

Is there any hope?


  • Reply 1 of 3
    Update on my own post - after reading an old message in the Apple support forum that suggested turning off "Wake on Ethernet" in the Energy Saver control panel, I decided to give it a try. No, I had never explicitly turned it on - it was just on. That was last night. Today I had my 13-year old son run through his usual repertoire of freeze-inducing activities - Rise of Nations, Starcraft, Nanosaur 2, etc. Even So far ... NO FREEZE. I am cautiously optimistic.

    Power Mac G5 is running Tiger 10.4.3, I have a home network with a Linksys router, an old iMac, PC laptop, and SLIMP3 player in addtion to the G5.

    Please reply if this helps you, or if you have tried it without success.
  • Reply 2 of 3
    outsideroutsider Posts: 6,008member
    We had this problem with one of our 1.8 G5s but we narrowed it down to a KVM switch. When we took it off the switch, a switch we use for troubleshooting trouble macs, it was fine.

    I think our issue was video card related.
  • Reply 3 of 3

    Originally posted by Outsider

    I think our issue was video card related.

    That seems like a logical conclusion. My "freezes" have almost always been associated with starting or quitting a full-screen Open GL application. But the computer still lives. It's a BSOND (Black Screen Of Near-Death). You can still SSH from outside and reboot gracefully. But nothing can be done from the Mac keyboard or mouse. What (if anything) this has to do with "Wake on Ethernet" is beyond me, but I'm leaving that box unchecked for now. Especially since I've already followed Apple's instructions and disabled sleep entirely.
Sign In or Register to comment.