Troubleshooting macOS Sierra: Wired networking, ScanSnap, Bluetooth

in macOS edited September 2016
While early AppleInsider tests have found Sierra to be a solid update for Mac users, every new software release has trials and tribulations for users to work through. Here are the first few that we've run into, and some possible solutions.

Some wired network configurations need minor massaging, or old gear replacement

AppleInsider has learned that some wired network hubs with 10-base-T connectivity suffer from sporadic or slow data transfers, under some circumstances involving transfers to or from Sierra-equipped hardware.

The solutions for the problem are relatively simple. Dual-speed 10/100 switches and hubs or triple-speed 10/100/1000 devices generally just need a reset. In rare cases, a hub needs to be replaced, but every switch we've seen the problem with just needed a power-cycle.

The problem does not appear to manifest with routers with multiple speeds, or in 100/1000 network switches.

Fujitsu ScanSnap users shouldn't update to Sierra

At present, users with Fujitsu scanners using the ScanSnap software should avoid Sierra at this time. Not only does the factory driver not function properly, but PDFs generated with the software don't render correctly with the macOS Sierra Preview application.

AppleInsider has learned that Fujitsu scanners compatible with TWAIN can use the third-party VueScan software.

Some Bluetooth peripherals that worked under El Capitan no longer work

As part of the Bluetooth SIG, Apple stays on top of the latest errata for the Bluetooth protocol. As a result, some hardware that does not adhere to the specification so strictly may not work properly as Bluetooth has fixes applied incrementally between generations.

Power-cycling and re-syncing all involved devices sometimes fixes the problem. If functionality is still compromised, the option remains to revert to El Capitan.

Some hardware manufacturers do ultimately issue firmware updates for the latest Bluetooth protocol updates in a timely fashion, but most do not. As a result, even high-end Bluetooth products like hearing aids or in-car entertainment solutions may not work properly after an Apple software update.

MacOS Sierra appears to be one of the most problem-free initial version releases in some time. However, AppleInsider still recommends that all users that have a critical need involving computer hardware, to not update to any new version of any operating system until proper functionality of software or hardware necessary for a task is confirmed by the manufacturers or other users.


  • Reply 1 of 18
    Any fix for the slow performance of the new console logging system?

    btw it's the other way around: ScanSnap
  • Reply 2 of 18
    In ScanSnap colour PDFs are fine but if you scan a mono document the file size is quite large
  • Reply 3 of 18
    I've been using Sierra for over a month (upgraded to the final version today) and ScanSnap has worked fine for several weeks. I had to download version 3.2.80 from Fujitsu, but the quality is good, the file size normal and it opens in Preview.
  • Reply 4 of 18
    My late 90's Zip drive doesn't work with Sierra, :(
  • Reply 5 of 18
    MacProMacPro Posts: 19,784member
    That's weird, I've been run all the developer versions of macOS Sierra and had no issues using a Fujitsu ScanSnap whatsoever.  This both on a new Mac pro and a MacBook Air.  I did learn just however, it's correct name.  I've always read the name as SnapScan!  lol

    edited September 2016
  • Reply 6 of 18
    Ditto on ScanSnap. Update from 10.11. No issues far.
  • Reply 7 of 18
    My ScanSnap is the ix500 with their latest software.
  • Reply 8 of 18
    I too have been running the betas of Sierra from day one, and had some brief problems with the ScanSnap software device, which were rectified by the second or third beta. I've been running the GM (both the first and the revised version) and ScanSnap works just fine.
  • Reply 9 of 18
    MacProMacPro Posts: 19,784member
    spice-boy said:
    My late 90's Zip drive doesn't work with Sierra, :(
    When I read what you wrote I dug my old Zip drives out.  The USB one works fine on my new Mac Pro running macOS Sierra, read and write.  The older SCSI Zip drive I left alone ;)
  • Reply 10 of 18
    Problems I've noticed on my Late 2013 Mac Pro (6-core 3.5GHz Intel Xeon E5, 64GB RAM, dual AMD FirePro D700):
    - My internal microphone is no longer displayed as an input in System Preferences > Sound. This means I can't use Siri. Resetting the PRAM hasn't helped.
    - I have an Asus PA328 4K monitor connected via mini DisplayPort. When I reboot, the monitor says there's no signal. If I plug in my old Apple 24-inch LED Cinema Display I get no signal on that either so I have to force a power down and restart (hold in the power button on the Mac). I then see the Reset Password screen on the Cinema Display and still nothing on the Asus. The Mac doesn't boot to the login screen anymore. FileVault 2 is enabled, which is why the Reset Password screen is enabled, but my 4K monitor simply doesn't receive a signal from the Mac anymore. Also, why is the Reset Password screen being displayed and not the login screen?
  • Reply 11 of 18
    My 1997 LG lightscribe external drive doesn't work either but then again, it didn't since Mavericks. My external bluray drive should. I'll probably wait a couple of days before I do install Sierra. I'll update everything and do a clone as I do before every new OS install.
  • Reply 12 of 18
    I had to abandon Blutooth altogether on my Mac Pro (late 2013) under Yosemite and El Capitan because of the constant dropouts.
    There's a lot online about this problem.  I was really hoping they were going to fix the issue on this version.

  • Reply 13 of 18
    Looks like the Samsung Portable SSD Software for my SSD T1 drives has stopped working with Sierra.  Crashes immediately.  I used it w/o probs to backup prior to updating to Sierra; subsequently it doesn't work.
  • Reply 14 of 18
    Hmm, my Apple Newton MessagePad 2100 doesn't seem to be syncing with iCal under Sierra. Disappointing, Apple!
  • Reply 15 of 18
    Basically as soon as I went from the last public beta to the GM, my Time Capsule wifi turned to crap and everything that required internet access became impossible. I reinstalled the public beta over the GM and everything was fine. Because I have been unable to find anyone who has this problem and knows a fix, I don't dare install the normal release in case I'm unable to revert to the public beta again because it's been pulled or something. Also, another machine on the same network was never able to do a Time Machine backup again, in either the public beta or the GM. Everything's fine now, but I don't plan on going further with Sierra until I'm able to replace my Time Capsule to a newer model. As far as I can tell there was never any information released to indicate that my Time Capsule was not supported. 
  • Reply 16 of 18
    jdgazjdgaz Posts: 405member
    Are updates being pushed to compatible computers? I don't see it when I try to check for an upgrade via about this mac. I could download form the App store, but have never had to do that. 
  • Reply 17 of 18
    I'm a bit stunned at how little attention this gets.  Perhaps I am reading the urgent message ( I stumbled upon, have not received email from Fujitsu about it) wrong, but as I read it any PDF i've created with a scan snap product in the past could be blanked permanently if I open it in preview on os X  sierra and save it.  Seems to me this should be an urgent apple message as much as a Fujitsu message.   I obviously naively have thought a pdf was a pdf and would be readable a decade from now.  
  • Reply 18 of 18
    gatorguygatorguy Posts: 24,387member
    ...and the problem is back with the latest update, 10.12.2
Sign In or Register to comment.