What's new in macOS 10.13.5: Messages in iCloud

2»

Comments

  • Reply 21 of 34
    Now update icloud email for syncing.
  • Reply 22 of 34
    vicpvicp Posts: 11member
    macseeker said:
    macseeker said:
    I don't see the Messages in the iCloud setting in Messages Preferences. Mac Pro 5,1 (Mid 2012). Updated to macOS 10.13.5.
    On your Mac go to Messages app > preferences > Accounts tab > and enable messages in cloud.
    Thanks, but I don’t see the iCloud feature in the Account section.
    I have the same problem that macseeker and others have mentioned. I installed the upgrade, but my iCloud account under Messages preferences doesn't show that option.





    And as with everyone else who answered the the various users who asked why I would want message in iCloud, it's primarily so that I don't have to delete a message on my Mac, my iPhone, and my iPad.
    watto_cobra
  • Reply 23 of 34
    asciiascii Posts: 5,941member
    vicp said:
    macseeker said:
    macseeker said:
    I don't see the Messages in the iCloud setting in Messages Preferences. Mac Pro 5,1 (Mid 2012). Updated to macOS 10.13.5.
    On your Mac go to Messages app > preferences > Accounts tab > and enable messages in cloud.
    Thanks, but I don’t see the iCloud feature in the Account section.
    I have the same problem that macseeker and others have mentioned. I installed the upgrade, but my iCloud account under Messages preferences doesn't show that option.
    Have you got 2-factor authentication enabled for your iCloud account? I believe that is a requirement to use Messages in the cloud.
    watto_cobra
  • Reply 24 of 34
    Charles1: No. There is a long list of very important security fixes in this update as well, and various other bug fixes which are significant.
    charles1 said:
    Is this ALL that's in this update? Yeah I saw one obscure bugfix, but this has to be the most minor 00.1 update ever.
  • Reply 25 of 34
    vicpvicp Posts: 11member
    ascii said:
    vicp said:
    macseeker said:
    macseeker said:
    I don't see the Messages in the iCloud setting in Messages Preferences. Mac Pro 5,1 (Mid 2012). Updated to macOS 10.13.5.
    On your Mac go to Messages app > preferences > Accounts tab > and enable messages in cloud.
    Thanks, but I don’t see the iCloud feature in the Account section.
    I have the same problem that macseeker and others have mentioned. I installed the upgrade, but my iCloud account under Messages preferences doesn't show that option.
    Have you got 2-factor authentication enabled for your iCloud account? I believe that is a requirement to use Messages in the cloud.
    Yes, I do. Serendipitously, I signed in to my iCloud account to double-check that I was using the same account alias everywhere (mac.com, not icloud.com) and I accidentally did it from Chrome, instead of Safari as I normally do, and received the 2-factor prompt as a new "device".

    I also was able to setup iCloud messages just fine on my iPhone and iPad after the IOS updates, and they synced fine, with one issue. On the iPad, when I go to iCloud->Manage Storage->Messages, Conversations shows 86.2MB. But on the iPhone, it varies. When I started this reply and checked, it was saying Zero KB; I just checked again and it says 54.5MB. On both devices, the Messages app shows the same amount of storage (currently 143.1MB). I checked the iPhone a few times after the IOS upgrade and enabling iCloud messages, there, and the Conversations has gone back and forth between Zero and some number of MB.

  • Reply 26 of 34
    sphericspheric Posts: 1,798member
    ivanh said:
    It seems that fans are excited about storing Messages in iCloud.  What're the benefit of doing so?
    If you’re not the type of person who reads a string of messages one after the other to maintain context of what’s going on (and from your post in this thread, you don’t seem to be), then there is no benefit. 

    Don’t worry about it.
    IreneWwatto_cobra
  • Reply 27 of 34
    vicp said:
    ascii said:
    vicp said:
    macseeker said:
    macseeker said:
    I don't see the Messages in the iCloud setting in Messages Preferences. Mac Pro 5,1 (Mid 2012). Updated to macOS 10.13.5.
    On your Mac go to Messages app > preferences > Accounts tab > and enable messages in cloud.
    Thanks, but I don’t see the iCloud feature in the Account section.
    I have the same problem that macseeker and others have mentioned. I installed the upgrade, but my iCloud account under Messages preferences doesn't show that option.
    Have you got 2-factor authentication enabled for your iCloud account? I believe that is a requirement to use Messages in the cloud.
    Yes, I do. Serendipitously, I signed in to my iCloud account to double-check that I was using the same account alias everywhere (mac.com, not icloud.com) and I accidentally did it from Chrome, instead of Safari as I normally do, and received the 2-factor prompt as a new "device".

    I also was able to setup iCloud messages just fine on my iPhone and iPad after the IOS updates, and they synced fine, with one issue. On the iPad, when I go to iCloud->Manage Storage->Messages, Conversations shows 86.2MB. But on the iPhone, it varies. When I started this reply and checked, it was saying Zero KB; I just checked again and it says 54.5MB. On both devices, the Messages app shows the same amount of storage (currently 143.1MB). I checked the iPhone a few times after the IOS upgrade and enabling iCloud messages, there, and the Conversations has gone back and forth between Zero and some number of MB.

    I think you need 2-factor authentication AND iCloud keychain syncing enabled.
    watto_cobra
  • Reply 28 of 34
    Andrew_OSUAndrew_OSU Posts: 268member, editor
    ivanh said:
    MacPro said:
    dougd said:
    Why do you need messages in iCloud?
    I think it syncs better across devices.
    The only difference between Apple Cloud and iCloud for iMessages, is that you may need to pay for iCloud for iMessages now while in the good old days you don’t.  
    Not at all true. Not even close. Before if you delete a message on your iPhone, it doesn't get deleted on your Mac. Same in reverse. Same goes for entire conversations. Before, which mind you is still around, you don't have to use Messages in iCloud, the only that happened was any incoming message would go to all devices. That is it. There was no synchronization.

    Additionally, it saves a Ludacris amount of space. I had over 36 GB of storage taken up by messages on my iPhone and also on my Mac. By using this, that goes to almost nothing. Between Messages in iCloud, and iCloud Photo Library, I don't need such a large amount of storage on my phone.

    Lastly, it keeps everything in check when you go to a new device. I don't usually restore new devices from a backup, instead, I just sign into iCloud. Now when I do that, my entire message history comes along.
    Soliwatto_cobra
  • Reply 29 of 34
    mac_128mac_128 Posts: 3,453member
    ivanh said:
    MacPro said:
    dougd said:
    Why do you need messages in iCloud?
    I think it syncs better across devices.
    The only difference between Apple Cloud and iCloud for iMessages, is that you may need to pay for iCloud for iMessages now while in the good old days you don’t.  
    Not at all true. Not even close. Before if you delete a message on your iPhone, it doesn't get deleted on your Mac. Same in reverse. Same goes for entire conversations. Before, which mind you is still around, you don't have to use Messages in iCloud, the only that happened was any incoming message would go to all devices. That is it. There was no synchronization.

    Additionally, it saves a Ludacris amount of space. I had over 36 GB of storage taken up by messages on my iPhone and also on my Mac. By using this, that goes to almost nothing. Between Messages in iCloud, and iCloud Photo Library, I don't need such a large amount of storage on my phone.

    Lastly, it keeps everything in check when you go to a new device. I don't usually restore new devices from a backup, instead, I just sign into iCloud. Now when I do that, my entire message history comes along.
    Right, but here’s what I want to do, much the way I handle Mail on all of my devices:

    With iCloud Messages on the Mac, can I adjust these settings between devices such that, if I delete a message or thread on my iPhone or iPad, that it will stay untouched on the Mac? 

    The way I have Mail setup, if I delete e-mail on my iPhone, they remain on my Mac. Then the Mac is set never to delete the e-mails locally, even as it is set to delete them from the server, so it serves as my archive.

    Messages on my Mac serves as my archive, some date back to 2010. There are no threads on my iPhone or iPad that date back that far. What I don’t want to happen is to turn on Messages in the cloud, and have all the messages on my Mac back to 2010 deleted because they aren’t on my iPhone and iPad.  Going forward, I don’t want a message deleted on my iPhone or iPad, to delete that message from my Mac. I don’t really care what’s in iCloud,  but I don’t want my Mac affected by it once a message has been downloaded to it. That also means, that since my Mac is not always on, until my Mac receives a new message, it can’t be deleted from the original source. This is more or less how it works now. Is this how messages will continue to work? Or will the Messages server now send the incoming messages to iCloud to be pushed down to the devices? 

    I’ll probably wait wait a while before I start playing with this feature until I see the reports that all the bugs are worked out and assurances that it works the way I need it to.
  • Reply 30 of 34
    tallest skiltallest skil Posts: 43,399member
    Andrew_OSU said:
    I had over 36 GB of storage taken up by messages on my iPhone and also on my Mac.
    Either my digital social life is pathetic or I’ve just become a LOT happier. Mine was only 500MB when I tested it. I turned it off, though. I’m not sure it’s necessary to keep every single last bit of minutiae in perpetuity.
  • Reply 31 of 34
    macmarcusmacmarcus Posts: 65member
    ascii said:
    You got this up quick!

    I just set it up myself. You enable Messages in iCloud in iCloud settings on your phone but in the Messages app on the Mac which is inconsistent. There is a "Sync Now" button in Messages on the Mac too, but it wasn't needed when I initially set it up, a bunch of messages which were only in the cloud (having been uploaded from my phone yesterday) came down to the Mac automatically. So what is that button for going forward I wonder? Is there the potential for it to get out of sync in some scenarios? 
    According to Apple Help

    "Sync Now

    When Messages in iCloud is turned on, all your texts appear on all your devices automatically. However, if you want to make sure you’re seeing the most up-to-date messages on your Mac—for example, if you just switched to a new Mac—you can click Sync Now."

    watto_cobra
  • Reply 32 of 34
    SoliSoli Posts: 9,378member
    Andrew_OSU said:
    I had over 36 GB of storage taken up by messages on my iPhone and also on my Mac.
    Either my digital social life is pathetic or I’ve just become a LOT happier. Mine was only 500MB when I tested it. I turned it off, though. I’m not sure it’s necessary to keep every single last bit of minutiae in perpetuity.
    Have you been saving all your iMessages “Forever”? I only started doing it on my iPhone about 1.5 years ago when I got a higher capacity device, but my Mac has probably set to “Forever” since iMessages launched.
  • Reply 33 of 34
    sflocalsflocal Posts: 4,752member
    With my using three Apple devices, this feature is a godsend.  I was reaching a boiling point with maintaining theee different sets of iMessages.  It’s also nice that I no longer have to worry about always backing up my messages database on my iMac when re-installing the OS from time-to-time.
    watto_cobra
  • Reply 34 of 34
    asciiascii Posts: 5,941member
    For those it is not working for, note that there is one additional step on your phone after turning on iCloud Messages in iCloud settings. You have to then open the Messages app, and after a few seconds there will be a message pop up at the bottom of the screen saying something like "Waiting to upload messages to the cloud, please plug in device and connect to WiFi."

    Basically it won't do that initial sync over cellular and it won't do it unless you're connected to power.
Sign In or Register to comment.