How to back up your iPhone or iPad to an external drive to save space on your Mac



  • Reply 41 of 54
    Thank you! This is just what I needed! I just have a follow up question: when I get a new MacBook in the future, will this trick still work when backing up into iTunes or will I have to do it all over again?
  • Reply 42 of 54
    FcarzoglioFcarzoglio Posts: 1unconfirmed, member
    Hey, thanks for the tutorial. I followed all the steps but when I hit return in Terminal, it says "operation not permitted". Did this happen to any of you? Please help.
    edited January 2019
  • Reply 43 of 54
    I get this message and can't figure out why! Followed all the steps exactly including the correct drive and folder name. Any help would be appreciated.

    ln: /Users/josh/Library/Application Support/MobileSync/Backup: Operation not permitted

  • Reply 44 of 54
    Great stuff.  Just wondering if say my external hard drive is called Peter's Brain, does it work on Terminal and how should I code it?  Also, when I copy my original Backup folder onto the external HDD, does it go UNDER the newly created folder? Many thx!
  • Reply 45 of 54
    KillerproofKillerproof Posts: 1unconfirmed, member
    Hi, I tried doing this but Terminal gave me back this: ln: /Users/MyName/Library/Application Support/MobileSync/Backup: Operation not permitted What should I do?
  • Reply 46 of 54
    EnnoEnno Posts: 1unconfirmed, member
    Thanks a lot. I used this article as a guide. Very useful, described well, was able to follow along easily.
  • Reply 47 of 54
    I tried to do this but couldn't make it work. After attempting to undo the symlink, now my computer says it's unable to backup my iPhone. Any suggestions?
  • Reply 48 of 54
    micheleschubmicheleschub Posts: 1unconfirmed, member
    hey! so i had done this before but then for some reason it stopped working. I was trying to do it again but now it doesnt seem to work. I can set up the link but the "alias arrow" doesn't appear on a folder icon but on a empty document icon, when i click it it tells me "the original object can't be found" I AM DESPERATE PLS HELP
  • Reply 49 of 54
    leichter said:
    The Terminal command shown is backwards! The syntax is: ln -s So what you should be typing is: ln -s ~/Library/Application\ Support/MobileSync /Volumes/Sierra/BackupiPhone/Backup/ By the way, spaces in the link name are perfectly OK - you just have to "hide" them on the command line. There are (at least) three different ways to do this - one of which is actually shown in this line, where the space in "Application Support" is "hidden" by putting a backslash in front of it. This will work just fine on the link's name as well. (You can also put the whole name in single or double quotes). -- Jerry
    Hi folks I hope someone can help me! Sorry I know this thread is old, but I did what leichter said here and then realised as others have said that the command line in the original article is correct. Now when I try to enter that command, I get the reply “file exists” in terminal. The alias icon doesn’t appear anywhere. Do I need to somehow undo the command that leichter said? Could someone please advise me regarding what I need to type into terminal? Thanks in advance!
  • Reply 50 of 54
    Hi, when you have spaces in your directory name, just surround the directory name in double quotes and all is good.
    edited October 2019
  • Reply 51 of 54
    Hi. When I try to run the command in Terminal, I get the message: "Operation not permitted". Any hints on what to do? I also tryed it in sudo su root, but notting happens.
    edited January 2020
  • Reply 52 of 54
    Thank you for this tutorial!

    I thought I did everything right until I synced my iPhone at the end and did not see a new backup. When I click on the symlink, I get this error message: the operation can't be completed because the original item for "backup" can't be found.

    Do you know what I did wrong and how I can fix it? THANK YOU in advance!! :)
  • Reply 53 of 54
    It's me again, I think I see what's wrong. Inside my BackupiPhone folder is a Backup folder and then inside that is another folder with all those I have an extra folder?
  • Reply 54 of 54
    I have plenty of space on my harddrive and after following the instructions exactly it still says Iphone cannot backup because this computer does not have enough space. Any reason why this is not working for me?
Sign In or Register to comment.