How to fix Apple's App Store bug about 'accepting' apps before an update

in General Discussion edited October 2020
If your Mac won't let you update one of Apple's apps until you click on 'Accept,' here's what to do when there is no such button.

This example is of Keynote, but you can get it with Pages, Numbers, or even Safari
This example is of Keynote, but you can get it with Pages, Numbers, or even Safari

It's only when downloading apps goes wrong that we really appreciate how amazing it is that we can ever do it. Even if you can remember the days when software came in boxes that you bought from shops, you can't actually remember them because they seem so long ago and just so very wrong.

Apple changed the world in this way, Apple made it obvious that you should download software -- but just occasionally, it's Apple who makes it stop working.

Right now, if you have certain Apple apps installed on your Mac and a new version comes out, your Mac may block you from downloading them. It's the Apple app, such as Pages or Numbers, that will tell you there's an update, and it's Apple's macOS that will take you to Apple's Mac App Store, but that smooth, unbroken path through the Apple ecosystem sometimes comes to an abrupt halt.

"To update this app," says the App Store dialog box, "you need to accept it on the Account page in the App Store."

There's ambiguous and there's invisible

That's worded in typical Apple fashion in that it's simple and straightforward. It's worded in slightly unusual Apple fashion in that it's a bit ambiguous. Presumably by "the account page," it means your account page, as in what you get when you choose View My Account.

We'd rather not say what something presumably means, we'd rather take the time to find out where the Accept button is, but that's the problem.

While Apple's own support documentation specifically says that you should press an Accept button that is listed next to an app's name, good luck finding it.

Apparently some people do get this Accept button and they can therefore click on it with gusto, but for others, including AppleInsider there just isn't one. Seriously. No button.

We couldn't take a screenshot to show you where the button is supposed to be, because we can't get the App Store to show it to us.

What to do

Delete the apps.

There you go, that's it, just delete Numbers or whatever the app causing this problem is, and then go re-install it from the App Store.

When that's done, you'll have the latest version of the app installed on your Mac just as you would expect. This problem is too recent for us to know whether that will stay fixed for the next time there's an update, though.

Maybe the missing Accept button is tied to the seemingly still not resolved bug that sees the App Store pretend you have few or no previous purchases.

We'd rather Apple fixed that one completely, and in comparison the acceptance one is only mildly inconvenient.

Yet it's also downright peculiar. It's hard to see how it can be a technical issue, a legal one or a security procedure.

It's especially hard to see it as a security measure for two reasons. The first is that every step of this is controlled entirely by Apple, from your app telling you there's an update to the Mac App Store refusing to give it to you. There's no question of authentication or of someone managing to get into your account to maliciously buy an app that you've already got.

And then if it were some security issue, look at what happens when you fix it.

When you actually had the app installed, the Store made this big deal about how you had to confirm that you accepted it. Now you don't have it, the Store will let you download the latest version without blinking.

There's got to be a reason, but it doesn't look like it can be a good one. Not when Apple's support documentation promises you that there's an Accept button you need to press, but then it spends exactly as long again telling you what to do if this doesn't work.

Keep up with AppleInsider by downloading the AppleInsider app for iOS, and follow us on YouTube, Twitter @appleinsider and Facebook for live, late-breaking coverage. You can also check out our official Instagram account for exclusive photos.


  • Reply 1 of 9
    I can't remember having seen an "Accept" button anywhere ever. Is this a USA thing?
  • Reply 2 of 9
    Re: button madness

    I've noted a sorta-similar issue in the last few versions of Safari for Mojave. If you have Enable Content Blockers checked for a given website (the Safari default), and you've filled in info fields to register for a site, the submit/enter/continue button often won't work—you have to disable the Content Blockers setting on the website just to submit your info. I hope this bug gets addressed in a minor, end-of-the-line Mojave update (which supposedly has already happened) as well as in Catalina.
    edited July 2019 hagar
  • Reply 3 of 9
    bradmacprobradmacpro Posts: 122member
    This happens when you get a new Mac, but with slightly older software installed. You have to sign in with your Apple ID in the iCloud System Preferences and in the App Store, then you can proceed with the System Updates from Software Update System Preferences and the application updates from the App Store. I also had this dilemma of no Accept in some cases and as they are all free apps, I deleted them in the Finder, the update need disappeared from the App Store - Updates page and I then switched to discover and used the search to find iMovie, Pages, Keynote, Numbers, GarageBand and it shows as a iCloud download icon perhaps or just the usual Get for free applications. Download and install and you're good to go.
  • Reply 4 of 9
    ivanhivanh Posts: 597member
    It happens when the apps are developed by Apple and pre-installed in a Mac when you purchased the Mac and add some bundled apps at big discount as a university student or staff from the Apple Online Store.  I guess the pre-installed apps are stored in the Recovery Partition. I met the problem since 2015.

    Some updates are not applied and there’s no reason you pay to purchase them “again” because these apps were supposed to be free.

    When you use Family Sharing, some pre-installed apps can also be installed on other Macs but the updates of them may not be found. A lot of problems related to the iCloud but you can’t find enough iCloud support across multiple devices and multiple platforms.
  • Reply 5 of 9
    This happened to me after my Mac was repaired two weeks ago. When I tried to open the apps, I would get the notification repeatedly but no Accept button. I deleted the apps and reinstalled, and the notification went away.
  • Reply 6 of 9
    anantksundaramanantksundaram Posts: 20,407member
    My more salient problem with app updates is: (1) An unusually large number of App updates that show up every single morning, and with increasing frequency (often Apps I feel like I had just updated a couple of weeks prior) — and no, I do not have a more-than-average number of Apps; (2) I hit “Update All”, and a high proportion usually refuses to take the bait — and no, my internet is not slow. 

  • Reply 7 of 9
    XplinXplin Posts: 1member
    Something similar. On my iMac I've MacOS 10.13.6 and iTunes Some days ago, iTunes started to notify me iOS app that have updated versions but it wont to download them at all. For Apple Books a window alert me "This app is only available on iOS. To get this app, search for it on the App Store from your iOS device". For some other iOS App (Magisto, Spotify, WeChat, eg) a different window says "This item is currently not available". Never seen this situation before. Any ideas how to solve. TIA
  • Reply 8 of 9
    crowleycrowley Posts: 10,453member
    Thanks!  I have this problem with all of the iWork apps on my new MacBook Air, and was at a loss about what to do about it.
  • Reply 9 of 9
    What will happen to any saved files I have in those apps if I delete the apps? I have movies, documents, etc. created using those apps, and I don't want to lose them.
Sign In or Register to comment.