Appleinsider not working in Safari

Posted:
in Feedback
I have a problem where the main Appleinsider web site does not load at all in Safari, but loads instantly in Firefox. I have had this problem intermittently for months, but it seems to be a permanent problem now.

All other sites I use load quickly/perfectly, but the Appleinsider web site just stalls forever. The appleinsder forums do load OK.

Comments

  • Reply 1 of 16
    Mike WuertheleMike Wuerthele Posts: 6,094administrator
    antonypg said:
    I have a problem where the main Appleinsider web site does not load at all in Safari, but loads instantly in Firefox. I have had this problem intermittently for months, but it seems to be a permanent problem now.

    All other sites I use load quickly/perfectly, but the Appleinsider web site just stalls forever. The appleinsder forums do load OK.

    Any Safari plug-ins? I've never seen the problem, and certainly not all the time even if there is a momentary hiccup.
  • Reply 2 of 16
    jSnivelyjSnively Posts: 351administrator
    Can't reproduce anything like this. Rouge ad maybe? Can you DM me your version of macOS & safari and your general geographic location (state level is fine)
  • Reply 3 of 16
    Hi. I am still having a problem with Appleinsider and Safari. I am running Catalina 10.15.1 in the UK.

    This morning I couldn't get the site to load, it just stalled every time. I switched off Javascript using the Safari Develop menu and then the site loaded perfectly (without adverts). I then switched Javascript back on and again it loaded perfectly (with adverts this time).

    I am beginning to think it is an advert causing the problem. I do not use any Safari extensions. I do not see with problem with any other site I use.

    edited November 2019
  • Reply 4 of 16
    In the past day or two, the site does not load.  I do use 1Blocker (have for ever).  If I disable Javascript in the developer menu, the site loads IMMEDIATELY - quicker than I have EVER seen it load.  At least for me, in the past couple of days, Javascript is definitely causing an issue.
  • Reply 5 of 16
    Problem still exists today for the main site - never loads with Javascript enabled.  Directly to the forums, like here, works, but the main page does not.
  • Reply 6 of 16
    jSnivelyjSnively Posts: 351administrator
    We think it's an ad and we are trying to nail it down. We're having a tough time reproducing via our VPNs of choice (it seems to only be affecting certain UK users.) Unfortunately, these things can take time as they are fairly inconsistent. I will keep you all posted.
  • Reply 7 of 16
    I'm in the US and the problem still persists today. With Javascript enabled, it's been constantly broken for a couple of weeks now. Note that I normally use 1Blocker w/Safari, so maybe it's not an ad? 1Blocker on or off, and Javascript on, the main site will not load. I'm coming from a Comcast Business IP address normally: 73.103.70.x
  • Reply 8 of 16
    For the first time in a couple of weeks, the main site now works with Javascript enabled.  It did not earlier today, but it does now - Woot!

    If someone did something to fix it - THANKS!
  • Reply 9 of 16
    jSnivelyjSnively Posts: 351administrator
    If people are still having issues, please visit this page and let me know if it stalls for you:

    (We removed this ad provider from our site this morning, but just verifying.)
    edited December 2019
  • Reply 10 of 16
    TomETomE Posts: 166member
    jSnively said:
    If people are still having issues, please visit this page and let me know if it stalls for you:

    (We removed this ad provider from our site this morning, but just verifying.)
    No ad for me.
    Running latest Safari & OS. Everything Standard.
    It still has some stalling (Beachball).
  • Reply 11 of 16
    jSnivelyjSnively Posts: 351administrator
    TomE said:
    It still has some stalling (Beachball).
    The main site still has stalling, or the test page does?
  • Reply 12 of 16
    I'm having this problem also (frequent spinning beach ball, with AppleInsider Homepage not fully loading), with the main page, and with your test page linked above. JavaScript enabled. It's been happening since sometime after I upgraded to Catalina. Don't recall having the problem before that. No problem with other web sites. In Ohio, USA.
  • Reply 13 of 16
    Think I may have solved it for me. I went to Safari Preferences...---->Websites---->Content Blockers---> and saw that I the "Content Blockers" option turned On for AppleInsider. Once I turned it Off, pages so far have loaded fine. (Have it turned On "When visiting other websites", toward the bottom.  Your test add linked above still doesn't load, however. EDIT: Spoke too soon. Still having problems with A.I.
    edited December 2019
  • Reply 14 of 16
    I enjoy AppleInsider on the rare occasion it will work in Safari.  Usually your main page loads with beachballs so I close it.  No problem with the forums.  This has been the case forever for me; it is not a new behavior.

    I'm in the US.  The test page loads instantly but no ad is shown.

    My Safari extensions (as shown in its Preferences): 1Password (checkmarked), Adblock Engine (not checkmarked), Adblock icon (not checkmarked), StopTheMadness (not checkmarked).

    DM me if you would like me to try any specific tests.


  • Reply 15 of 16
    I have been having this problem for a good while, too. AI loads properly maybe 1 out of 5 attempts, but stalls all other times. It's the only site I visit where I have the problem. I have no Extensions enabled. Anyone else still seeing it?
  • Reply 16 of 16
    jSnivelyjSnively Posts: 351administrator
    I have been having this problem for a good while, too. AI loads properly maybe 1 out of 5 attempts, but stalls all other times. It's the only site I visit where I have the problem. I have no Extensions enabled. Anyone else still seeing it?

    Not sure what could be causing this. It's possible that some ad could be causing a mess, but usually when that happens we hear about it from a bunch of people.

    Are you located inside the US geographically? Can you give some more details on what version of macOS, Safari, and what computer you are using? 
    edited July 2020
Sign In or Register to comment.