How to make Preview in 10.3 behave like older versions: Resample image on Zoom-in

Posted:
in Mac Software edited January 2014
One of my favorite features about Preview has been the ability to zoom into an image and have it resample the pixels so that everything looked smooth. In 10.3 the pixels are not resampled when you zoom in, so the image is pixelated. As a graphic artist, I understand why you wouldn't want this, but is there a way to turn this behavior back on in Jag's Preview?

Comments

  • Reply 1 of 15
    kedakeda Posts: 722member
  • Reply 2 of 15
    Are you sure it doesnt do it? cause my works like that perfectly, of course you can only zoom in so far before the effect is lost and pixelation is just too much
  • Reply 3 of 15
    buonrottobuonrotto Posts: 6,368member
    Check your Preview preferences. There should be an option to anti-alias images in there somewhere.
  • Reply 4 of 15
    dglowdglow Posts: 147member
    Quote:

    Originally posted by BuonRotto

    Check your Preview preferences. There should be an option to anti-alias images in there somewhere.



    No, this featured disappeared with the arrival of Panther. There is an option to "anti-alias text and line art", but this option apparently applies to PDFs, not images.



    Jaguar Preview's image smoothing/interpolation was a really feature. I miss it too, Keda.



    Has anyone tried running Jaguar's Preview under Panther? I'd try it, had I not clean-installed 10.3...
  • Reply 5 of 15
    defiantdefiant Posts: 4,876member
    If I remember this correctly, you just have to zoom in, then wait a few seconds, while it resamples the image. Worked for me with a .jpg
  • Reply 6 of 15
    kedakeda Posts: 722member
    Thanks for the replies.



    I have looked in the Prefs...no luck. I wonder if there is a command line option for this.
  • Reply 7 of 15
    pbpb Posts: 4,231member
    Quote:

    Originally posted by Keda

    Thanks for the replies.



    I have looked in the Prefs...no luck. I wonder if there is a command line option for this.




    You could try to list the strings in the Preview binary and then make guesses about hidden preferences:



    strings /Applications/Preview.app/Contents/MacOS/Preview > previewstrings



    This will store the listing in the file 'previewstrings' in your current working directory for easy inspection. You will notice strings containing 'antialias' in several places. I don't know though how you could enable preferences this way. You can always try something like



    /Applications/Preview.app/Contents/MacOS/Preview -options file.jpg
  • Reply 8 of 15
    kedakeda Posts: 722member
    Thanks.



    I'm afraid thats a little too much for me to chew.



    Can anyone w/CLI experience try this. I know I'll break something.
  • Reply 9 of 15
    pbpb Posts: 4,231member
    Quote:

    Originally posted by Keda

    Thanks.



    I'm afraid thats a little too much for me to chew.



    Can anyone w/CLI experience try this. I know I'll break something.




    There is perhaps a more simple way. I am actually under Jaguar, I imagine it should be similar under Panther.



    In the terminal, you go to the ~/Library/Preferences/ directory and you type



    open com.apple.Preview.plist



    enter after that. This will open com.apple.Preview.plist in Property List Editor, where you can manually edit the Preview preferences. Once on Property List Editor, click the Root triangle, this will reveal you the available options. In Jaguar, first of all is antiAliasing, which would have the value 1 (double-click under the value column to edit the property value). If in your case it is 0, this would explain your problem. If it is already 1, then I don't know.



    So, after setting this value to 1, you save your com.apple.Preview.plist file (if prompted for the location, you go to ~/Library/Preferences/), and then you can relaunch Preview; now it should be OK.



    EDIT: you can do all previous work in the text editor of your preference. You simply open com.apple.Preview.plist in the editor of you choice, locate the antialiasing key, you change its integer value to 1 to activate antialiasing and you save the file.



    EDIT2: don't be afraid that you will break something. Even if you screw up your com.apple.Preview.plist file, simply delete it and by the next Preview relaunch, it will be automatically generated.
  • Reply 10 of 15
    kedakeda Posts: 722member
    I tried to open it, but got the following error:



    2004-02-25 13:27:52.923 open[622] Couldn't open file: /Users/keda/Library/Preferences/com.apple.Preview.plist
  • Reply 11 of 15
    kedakeda Posts: 722member
    I don't have Plist editor in my app folder, so I just found the plist in the finder and used text edit to open it. It looks like a bunch of code to me, but I found this at the bottom. Looks like Antialias is set to '1'. Do any of the other entries mean anything to you?



    <key>antiAliasing</key>

    \t<integer>1</integer>

    \t<key>autoOpenPDFThumbDrawer</key>

    \t<integer>0</integer>

    \t<key>continuousScroll</key>

    \t<integer>1</integer>

    \t<key>ignoreDPI</key>

    \t<integer>1</integer>

    \t<key>imageDefaultDisplay</key>

    \t<integer>0</integer>

    \t<key>loadAllThumbnails</key>

    \t<integer>0</integer>

    \t<key>mainWindowColor</key>

    \t<data>

    \tBAt0eXBlZHN0cmVhbYED6IQBQISEhAdOU0NvbG9yAISECE5T T2JqZWN0AIWEAWMDhAJm

    \tZgEBhg==

    \t</data>

    \t<key>pdfDefaultDisplay</key>

    \t<integer>2</integer>

    \t<key>pdfDefaultScale</key>

    \t<integer>100</integer>

    \t<key>respectDPI</key>

    \t<integer>1</integer>

    \t<key>scaleImagesPrinted</key>

    \t<integer>1</integer>

    \t<key>showPDFWidget</key>

    \t<integer>1</integer>

    \t<key>thumbnailDisplay</key>

    \t<integer>0</integer>

    \t<key>thumbnailSize</key>

    \t<integer>112</integer>
  • Reply 12 of 15
    pbpb Posts: 4,231member
    Quote:

    Originally posted by Keda

    I tried to open it, but got the following error:



    2004-02-25 13:27:52.923 open[622] Couldn't open file: /Users/keda/Library/Preferences/com.apple.Preview.plist




    Oh, perhaps you don't have the developer tools installed.
  • Reply 13 of 15
    pbpb Posts: 4,231member
    Quote:

    Originally posted by Keda

    Looks like Antialias is set to '1'. Do any of the other entries mean anything to you?



    <key>antiAliasing</key>

    \t<integer>1</integer>




    That's bad. That means the problem could be more deep in Panther, or perhaps it is something with your installation. We can't be sure without feedback from other users (apparently, dglow has the same issues).



    You can however play with the values 0 and 1 and see if it makes some difference (in Jaguar I see really the difference, especially in low quality PDFs), or delete the preference file and relaunch Preview to recreate it and then re-edit it. Don't forget to save the file after each editing.



    The other entries are without importance to antialiasing.
  • Reply 14 of 15
    pbpb Posts: 4,231member
    Quote:

    Originally posted by Keda



    \t<key>ignoreDPI</key>

    \t<integer>1</integer>

    .

    .

    .

    .

    \t<key>respectDPI</key>

    \t<integer>1</integer>





    That's strange, it looks like a conflict. You can try to remove either of the two (I would say keep "ignoreDPI" and remove the other first) and see if it makes some difference.
  • Reply 15 of 15
    chuckerchucker Posts: 5,089member
    I have the same issue, and yes, "antiAliasing" is set to 1. That value is probably limited to PDFs from Panther on.
Sign In or Register to comment.