Safari & Yahoo mail attachments

in Genius Bar edited January 2014
I just upgraded to 10.4.3 and Safari 2.0.2.

I use Yahoo mail most of the time but since the upgrade I cannot attach a file to my emails.

After I've selected the file to attach and click on the "Attach Files" button I get this error message:

Safari canÕt open the page ÒÓ. The error was: ÒPOSIX error: Invalid argumentÓ (NSPOSIXErrorDomain:22) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

This is a real bummer since I use Yahoo mail most of the time and need to be able to attach files. Any idea what the problem is and how to fix it.




  • Reply 1 of 1
    Problem Solved !

    Before I upgraded to Tiger, I was using Safari 1.3, I had the Safari Cashe Folder set to READ ONLY since I have Broadband High Speed, 6MB, because I didn't want that folder ballooning out of control and eating up disk space. Apparently that causes a conflict with Safari 2.0.2. Returning the Safari Cache folder to Read & Write solves the problem. You can't use Safari Enhancer to deactivate cache either as the problem returns.

    This seems like a bug to me. You should be able to deactivate cache if you want too without having major conflicts expecially since it worked fine under OS 10.3.9 and Safari 1.3.

Sign In or Register to comment.