Ugh Internet woes! Mac specific!!

Posted:
in General Discussion edited January 2014
Hello everyone,



More internet problems for me today.



The problem is that my internet runs terribly slow - JUST to load web pages. My bandwidth tests fast, and I can download files very fast as well.



The tech from Comcast came out today, on his laptop he saw very fast speeds for everything, on my iMac still slow...



Sooo I called Apple as the Comcast tech suggested. I was on the phone with Apple for 2 hours and still nothing has worked. They are having me reinstall my OS at this point to test.



But it doesnt make sense that a PC on my same connection works perfectly fine, while my Apple is sloooooooooooooooooow.



Any one have any bright ideas? Im all ears!@@!@



The Comcast tech said he has had like 10 calls in the last few weeks for this same problem, and has yet to find a solution..



Thanks,

Jeff

Comments

  • Reply 1 of 18
    Quote:
    Originally Posted by sgtpeper View Post


    Hell everyone,



    More internet problems for me today.



    The problem is that my internet runs terribly slow - JUST to load web pages. My bandwidth tests fast, and I can download files very fast as well.



    The tech from Comcast came out today, on his laptop he saw very fast speeds for everything, on my iMac still slow...



    Sooo I called Apple as the Comcast tech suggested. I was on the phone with Apple for 2 hours and still nothing has worked. They are having me reinstall my OS at this point to test.



    But it doesnt make sense that a PC on my same connection works perfectly fine, while my Apple is sloooooooooooooooooow.



    Any one have any bright ideas? Im all ears!@@!@



    The Comcast tech said he has had like 10 calls in the last few weeks for this same problem, and has yet to find a solution..



    Thanks,

    Jeff



    It sounds like what happens when you have manually set the DNS server to the wrong value. Try setting it to automatic.



    C.
  • Reply 2 of 18
    The DNS is set to automatic... Still nothing...
  • Reply 3 of 18
    irelandireland Posts: 17,746member
    Try Firefox and see is that slow too.
  • Reply 4 of 18
    Firefox is still slow....
  • Reply 5 of 18
    irelandireland Posts: 17,746member
    Just chill out and list all the things you did do already. And I don't mean calling Apple, I mean things you did to your computer to try and fix it.
  • Reply 6 of 18
    Restart the modem and router multiple times.

    Directly connected to the modem multiple times

    Connected wirelessly, connected wired

    Deleted cookies

    Cleared caches

    Tried creating a new user

    Stop all startup programs from loading on startup

    Tried other browsers - firefox, camino

    Reinstalled OSX with the save your options method

    Had comcast out for tech support - PCs can have fast internet without problem

    Spent maaaaannny hours on the phone...

    Reinstalled all updates for software..



    Thats all I can think of so far..



    This is my first Apple also.



    Im pretty calm though



    Jeff
  • Reply 7 of 18
    MarvinMarvin Posts: 14,440moderator
    If you are getting fast downloads, it definitely sounds like a DNS issue. If the PCs are fine then it can't be the router settings. Do you have to manually enter DNS servers into the PC or does it configure automatically?



    Maybe cleaning your DNS cache will work. I would have thought system reinstall and a new user should have helped. Open a terminal and type:



    lookupd -flushcache



    Also, you don't have any proxy settings or modifications to your hosts database?



    Another thing to try is turning off ipv6 in your network settings. Sometimes that's incompatible with DNS servers.
  • Reply 8 of 18
    Marvin-

    Auto DNS servers on Comcast

    I did the flushcache thing - no difference

    No, no proxy settings or mods to my hosts database that I know of

    I tried ipv6 off and for a second it was faster, then back to normal...



    Thanks!

    Jeff



    Quote:
    Originally Posted by Marvin View Post


    If you are getting fast downloads, it definitely sounds like a DNS issue. If the PCs are fine then it can't be the router settings. Do you have to manually enter DNS servers into the PC or does it configure automatically?



    Maybe cleaning your DNS cache will work. I would have thought system reinstall and a new user should have helped. Open a terminal and type:



    lookupd -flushcache



    Also, you don't have any proxy settings or modifications to your hosts database?



    Another thing to try is turning off ipv6 in your network settings. Sometimes that's incompatible with DNS servers.



  • Reply 9 of 18
    e1618978e1618978 Posts: 6,075member
    208.67.222.222

    208.67.222.220



    These are the OpenDNS name servers - since I switched I have had no problems,

    the Time Warner roadrunner DNS servers were very slow, and that is a thing

    of the past for me now.



    http://www.opendns.com/



    http://en.wikipedia.org/wiki/Open_dns
  • Reply 10 of 18
    I just put those in the DNS field correct??



    Should I turn ipv6 back on then?
  • Reply 11 of 18
    hirohiro Posts: 2,663member
    ignore.
  • Reply 12 of 18
    ignore what?
  • Reply 13 of 18
    Thats the strangeest thing.. I put in the ones on opendns - your second one is slightly different? But still it works pretty fantastic now! Soooo strange.



    I put the new DNSs into my router too and still things are working well.



    Thanks!
  • Reply 14 of 18
    Okay so with these DNS servers in, Ill have some spikes where everything runs fine and then some where the internet is pretty slow again...



    Argh...
  • Reply 15 of 18
    Quote:
    Originally Posted by sgtpeper View Post


    Okay so with these DNS servers in, Ill have some spikes where everything runs fine and then some where the internet is pretty slow again...



    Argh...



    Like I said originally. This sounds like a DNS problem.

    DNS is the service which converts URL names to IP numbers.

    If DNS is not working right, it can take several seconds before the look up happens. Which means every piece on a web-page can be delayed. The actual download of data is quick.



    In addition to your Mac, have you also checked your router(s) to see if there is a bad DNS entry in there? Has your ISP been having "issues"?



    Normally, the fastest DNS resolution is acheived if you discover your ISP's DNS server addresses and type them into your Mac's TCP/IP box. That assumes that your ISP is some good of course.



    C.
  • Reply 16 of 18
    Yep I have checked my router, it has no DNS entries in there - my ISP uses automatic DNS.
  • Reply 17 of 18
    hirohiro Posts: 2,663member
    Quote:
    Originally Posted by sgtpeper View Post


    ignore what?



    The stupidity I originally displayed and removed. It didn't take long for me to realize that, a couple seconds after posting, but you cant delete a post so... edit away!
  • Reply 18 of 18
    e1618978e1618978 Posts: 6,075member
    Quote:
    Originally Posted by sgtpeper View Post


    Yep I have checked my router, it has no DNS entries in there - my ISP uses automatic DNS.



    Un-check the "automatic DNS" box on your router (at least that is what the box is called on my Belkin) - you don't want to use your ISP's DNS. Just hard-code the DNS primary and secondary addresses to be the openDNS ones.



    I'm pretty sure that automatic DNS means that the hard-codes IP address you type in are ignored, in favor of ones supplied by your ISP at run time.
Sign In or Register to comment.