Leopard Upgrade Problems

in macOS edited January 2014

After reading some of the childish and/or arrogant responses to people posting Leopard problems here, I am rather reluctant to share my experiences. However, one never knows until one trys. So here goes.

My setup (prior to upgrade):

MBP 17 C2D 160 3GB running 10.4.10

Major apps:

MS Office

VMware Fusion with a 40GB partition running XP Pro SP2 (windows is a REQUIREMENT, not an option. for my work environment)

iTunes (38GBs and growing)

Gmail (In constant use due to work environment)

SuperDuper (best backup program I have ever used)

A little background:

While I am NOT a software developer, programmer or engineer, I do have extensive hardware development experience. That's why I am truly puzzled by some of the awful things that occurred during my install(s), and my subsequent challenges with Leopard.

First attempt:

I waited several days after the official launch before attempting to install. My first try was an upgrade, rather than a clean install. At first, things seemed to work OK, but then I started having problems staying online with Gmail and Safari in general. Next thing I knew I started having permission errors. Programs that had allowed access denied me access now.

Perplexed, I went to both the SuperDuper Forum and the Apple Discussion area. In both cases, the general sense of it was that my problems were more likely due to the upgrade path I had chosen, rather than Leopard itself.

Second attempt:

This time I did a clean install after a complete reformat and zero data wipe using Disk Utilities from the Leopard install disc. Next, I used the migration feature to transfer over all my files, etc from a clean 10.4.10 SuperDuper backup. Finally, Software Update ran and installed one update that I don't recall, then an update to the Keychain. And that's where the fun began.

Here's just a short list of the problems I encountered:

* Login account reset to Standard, instead of Admin

* Permissions across the board were completely hosed

* Apps that would open did not recognize my migrated docs

* Safari would still quit without reason after only a minute or two

* Gmail kept logging me out, saying that another browser had already logged in with my information (several forum threads indicated this was due to a change in Leopard, causing Gmail to think my Mac was a "robot" site)

* Address book wouldn't open at all.

* Adobe apps that had been migrated now wouldn't open and also suggested that they were bootleg apps. This kept occurring, even after I reregistered them using the Adobe tool.

* Entourage would not open my migrated database. I kept getting a bizarre message stating that I must move the Identity (my database) out of the Applications folder in order for it to open. Fine by me, but the Identity was never IN the Applications folder.

I ran diagnostic software and memtest to see if my hardware was causing any of the above. Everything reported clean.

Finally, after several days of absolute frustration, I completed a clean install of 10.4.10. Now everything is back to normal and I can actually get work done.

I am truly disappointed in this release. I have lived on the bleeding edge of updates for many, many years. But due to the critical nature of some of my work, I can no longer afford to compute in that fashion. I can honestly say that I have never before experienced the bizarre problems that I have encountered. But the sad part is how many others I have come across who experienced at least part of what I have seen. This is not the Apple that I once visited on a day-to-day basis, before the move to Infinity Loop, and it truly upsets me.

If you have to be a Unix geek to install this upgrade then Apple is going to lose a lot of the gains it has made in the past few years. I have no problems with Unix geeks - I even married one. But I am truly amazed by some of the responses, both here and elsewhere, that suggest the end user should have known better due to some obscure reference to underlying changes to the OS architecture. Are you kidding me? I love Apple, but aren't we supposedly to be the "user friendly" guys? My experiences over the past few days have been anything but friendly.

Your comments and suggestions are welcome


  • Reply 1 of 2
    I know what you mean about arrogant comments to people's posted problems. I would also add the word "condescending" to describe some of the unhelpful replies I've seen to posts of people having trouble. Good on you for having the courage to post anyway!

    Your setup doesn't sound too strange so one would have expected that Leopard's upgrade options should have worked for you. I too had problems when I tried to "upgrade"... it wouldn't let me log on (no sign of a password error; it went through the motions of logging on and then just took me right back to the login screen again as if nothing had ever happened). Then I discovered on a forum that some others who upgraded from Tiger had the same problem and the only solution that seemed to universally work was to do an Archive and Install overtop of the upgrade installation I had just done. So I did that and I could log on, but then I had some other serious problems (can't remember now). Ended up doing a clean install just like you, which is what I always used to do whenever I upgraded operating systems just to get rid of any old junk that was hanging around, but I kept hearing people on these forums say that that shouldn't be necessary with OS X so that was the first time I actually tried an upgrade... guess it'll be a long time before I try that again! Obviously though upgrading must usually work otherwise we'd hear about a lot more problems with it, so before I dump on Apple I guess I'd want to know if the problems you and I had are extremely rare, or not so much?
  • Reply 2 of 2

    OK, so I thought a happy ending to my frustrated attempts to move to Leopard might be in order, as I finally got things rolling this weekend. It wasn't easy to figure out, but for the sake of any others having similar problems as I did, there is hope.

    This last Friday I shared my frustrations regarding my attempts to install Leopard with a friend of mine. We are both Mac fanatics. The difference is that my friend has extensive tech support experience. They suggested I take Apple to task on this one and talk to an Apple Genius at the local Apple Store.

    When said Genius first booted my MPB 17 C2D, their first words would not pass the filters on this blog. He said them quietly, and mostly to himself, but he still muttered them. This, to me, was a good start. It meant that I wasn't crazy and the problems I was experiencing were abnormal. After answering his questions regarding my upgrade path (see original post) he used the Apple diagnostic tools on my trusty MPB. The hardware checked out fine. The install itself was another matter. He asked for my purchased Leopard package, which I had brought with me. He then disappeared to the back room of the store for several minutes. When he returned, my original Leopard software package was gone. It was replaced with a brand new one. He explained that the install disc was to blame and that the new one should correct the problems. I had read about these types of problems in Europe, etc. but I had not heard about this in the states.

    So, I went back to my office and first updated my SuperDuper 10.4.10 backup and made certain it was bootable. Then I began the entire clean install process again:

    * Zero Data wipe of the hard drive.

    * Clean install of Leopard

    * Migration of all files, apps, etc. from 10.4.10 Super Duper backup on My Book drive, using the built-in Migration option during the actual install.

    After the migration was complete, I did do a few things differently than previous installs. The major thing is I DID NOT let the Software Update function install any new updates until I had completed the following:

    * Made sure my own account had Admin capabilities

    * Opened each app that I need to use and made sure it had proper permissions, etc.

    * Checked to make sure Gmail was functioning normally

    * Checked Airport and networking in general to make sure all was well.

    Only then did I allow Software Update to continue. I also DID NOT install the Keychain update until all of the above had been verified again after all of the other updates were completed.

    Finally, I installed the Keychain Update. All of the apps still worked as advertised, with one exception. For whatever reason, VMware Fusion had a problem with bridged networking, saying that a "cable was disconnected". I played with their settings for awhile, but nothing changed. I downloaded and installed the latest beta update (build 61385) and now everything works there as well.

    So, fellow Apple folks, I guess an apology is in order? It was just very frustrating to do every possible thing by the book and still end up with a mess. The lesson I learned from all this is that if nothing works and nothing makes sense, then it just may be time to let a fresh set of eyes have a go at it. It certainly solved my problem.
Sign In or Register to comment.