Internet browsers are in cyrillic - help!

in Mac Software edited January 2014
Hi..I recently encountered a really strange problem on my PowerBook G4.

After downloading the new firefox update, all my web browsers (Safari & Firefox), display nearly all my sites in cyrillic (strangely and luckily enough, this isnt one of them)

Of course i checked my system settings and all is set in german (I'm german, so thats ok )

Anyone come across that problem? I dont want to format if theres another solution, obviiously....


PS: heres n example of a part of a page:

OOOkkkaayyy...gets stranger: I just wanted to paste copy part of a page, and after pasting the text was displayed correctly in this window.....?????

PPS: Upon further research: problem only seems to happen with german language sites...


  • Reply 1 of 3
    Additional InfO: gets stranger and stranger...ok, so its only normal fonts that are displayed incorrectly...bold and itals are fine for some obscure reason....

    Thx for the help!
  • Reply 2 of 3
    Try going up to VIEW, TEXT ENCODING and trying some of the ones there. I deal with Japanese sites a lot and sometimes need to switch settings to make them appear correctly.
  • Reply 3 of 3
    Tried every option, problem not solved!

Sign In or Register to comment.