Trouble with Boot Camp 3.1

in Genius Bar edited January 2014
I have a first generation aluminium iMac. It runs 10.6 and was running Windows Vista, but I upgraded to Windows 7 last year. I also purchased a Magic Mouse, which WIndows does not recognise. I was forced to get a corded mouse to try and upgrade to Boot Camp 3.1

However, software update did not show the update so I downloaded it manually. Whenever I tried to install the app would ask permission to run, then nothing for a long time and then an error message saying 'this program might not have installed properly'. I reinstalled Windows and Boot Camp drivers (everytime it gave an error message saying it could not install Apple bluetooth hardware as the device was disconnected). This time the update did appear in software update but whenever it asked to restart the machine the update would still appear in software update as though it had not installed properly. If I try a manual install I have the same problem as above. I've tried with my Macbook which is still running Vista and I have exactly the same problem re. the 3.1 update.

Anyone got any ideas how I can get it working? All I really want is for the magic mouse to work.


  • Reply 1 of 1
    not trouble with boot camp, but how does boot camp work? my work laptop PC died and i'm considering getting a mac book but need to run windows for work stuff
Sign In or Register to comment.