Help - Adobe Illustrator CS 5.1 won't launch

2»

Comments

  • Reply 21 of 31
    I really appreciate all your help. Here's the first chunk of the most recent crash log.



    Code:


    Process: Adobe Illustrator [10459]

    Path: /Applications/Adobe Illustrator CS5.1/Adobe Illustrator.app/Contents/MacOS/Adobe Illustrator

    Identifier: com.adobe.illustrator

    Version: 39 (15.1.0)

    Code Type: X86 (Native)

    Parent Process: launchd [223]



    Date/Time: 2011-12-10 00:39:49.392 -0500

    OS Version: Mac OS X 10.7.2 (11C74)

    Report Version: 9



    Crashed Thread: 0 Dispatch queue: com.apple.main-thread



    Exception Type: EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000034



    VM Regions Near 0x34:

    --> __PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Applications/Adobe Illustrator CS5.1/Adobe Illustrator.app/Contents/MacOS/Adobe Illustrator

    __TEXT 0000000000001000-00000000010de000 [ 16.9M] r-x/rwx SM=COW /Applications/Adobe Illustrator CS5.1/Adobe Illustrator.app/Contents/MacOS/Adobe Illustrator



    Application Specific Information:

    objc[10459]: garbage collection is OFF



    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0 dyld 0x8fe1e025 dyld::registerAddCallback(void (*)(mach_header const*, long)) + 61

    1 libdyld.dylib 0x9a921078 _dyld_register_func_for_add_image + 74

    2 libignitor.dylib 0x013fee76 initializer + 27

    3 dyld 0x8fe2c15b ImageLoaderMachO::doModInitFunctions(ImageLoader:: LinkContext const&) + 251

    4 dyld 0x8fe2bcc0 ImageLoaderMachO::doInitialization(ImageLoader::Li nkContext const&) + 64

    5 dyld 0x8fe29220 ImageLoader::recursiveInitialization(ImageLoader:: LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&) + 256

    6 dyld 0x8fe2a1c0 ImageLoader::runInitializers(ImageLoader::LinkCont ext const&, ImageLoader::InitializerTimingList&) + 62

    7 dyld 0x8fe1e626 dyld::initializeMainExecutable() + 166

    8 dyld 0x8fe22ef2 dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**) + 2238

    9 dyld 0x8fe1c2ef dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*) + 637

    10 dyld 0x8fe1c063 _dyld_start + 51



    Thread 0 crashed with X86 Thread State (32-bit):

    eax: 0x8fe1dff6 ebx: 0x0733a000 ecx: 0x013fee7c edx: 0x00000000

    edi: 0x8fe51d48 esi: 0x00000000 ebp: 0xbfffe9b8 esp: 0xbfffe990

    ss: 0x00000023 efl: 0x00010286 eip: 0x8fe1e025 cs: 0x0000001b

    ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f

    cr2: 0x00000034

    Logical CPU: 2



  • Reply 22 of 31
    MarvinMarvin Posts: 14,213moderator
    Quote:
    Originally Posted by Fireball1244 View Post


    I really appreciate all your help. Here's the first chunk of the most recent crash log.



    People on the Adobe forum with that issue said that same crash was caused by a keylogging application called refog:



    http://forums.adobe.com/message/3816924



    If refog isn't installed, it may be another app that does something similarly low level like Little Snitch.
  • Reply 23 of 31
    That's it, most likely. I tried out the trial version of that software a few months ago, just out of curiosity. Unfortunately, the program must be uninstalled through a menu command in the software itself, and my trial is expired. I'm searching now for a manual way to remove the files.



    Hopefully that will work!
  • Reply 24 of 31
    Thank you! That fixed it. I really appreciate you taking the time to help me track down this weird error, and finding interim solutions as we went. You're a life saver!
  • Reply 25 of 31
    MarvinMarvin Posts: 14,213moderator
    Quote:
    Originally Posted by Fireball1244 View Post


    I really appreciate you taking the time to help me track down this weird error



    Glad to hear that finally sorted it out. Those low-level apps sure can cause some odd behaviour.
  • Reply 26 of 31


    I don't have either one of those programs and I am having the same problems. I have tried all the above mention tests still no luck. I need some serious help!

     

  • Reply 27 of 31
    MarvinMarvin Posts: 14,213moderator
    I don't have either one of those programs and I am having the same problems. I have tried all the above mention tests still no luck. I need some serious help!

    If you find your crash report in /Users/<name>/Library/Logs/DiagnosticReports, post a similar portion of it to what was posted earlier.
  • Reply 28 of 31


    I know this is an OLD THREAD but I was running into the same problems a few days ago and "My Solution" was after I installed/updated Java...it launched without any problems. Hope this helps someone.

     

  • Reply 29 of 31


    Hi sbpait2408, what do you mean by 'My Solution' was after I installed/updated Java...  Do you mean the problem of error 16 was solved then? Can you help me, I shortly installed Java. What should I do? Regards, iMac1943

  • Reply 30 of 31

    Hi.

     

    I tried launching the program through the terminal but it's still stuck at 'initializing' screen.

    There seems to be no message from console about any errors.

     

    I am puzzled as it used to work perfectly but simply refused to launch the next day..

     

    Please help!

  • Reply 31 of 31



    I tried this and I got "segmentation fault: 11"

     

    Any suggestions?

Sign In or Register to comment.