Most frustrating problem ever: Slowness after sleep

in Genius Bar edited January 2014
I can't stand this. When I'm in OS 9 (9.x all of em) and I put my G4 to sleep, after I wake it up the computer is so sllloooowwwww. I mean its so slow that when I am typing this the text is drawing literally at 1 character a second. I'm about 2 sentences ahead of the type right now. And its not only screen draws. RC5 also drops down to 1 million keys/sec after sleep after being at 3.5million keys/sec before sleep.

This doesn't happen in OS X. If anyone knowsa fi for this it would GREATLY be appreciated


  • Reply 1 of 7
    jaydogjaydog Posts: 63member
    its the way OS 8.x to 9.x platform was built.

    OSX has been in develpmant for years. i wish it was a bit beter. OSX DP 1 was released in like 1993
  • Reply 2 of 7
    applenutapplenut Posts: 5,768member
    [quote]Originally posted by jaydog:

    <strong>its the way OS 8.x to 9.x platform was built.

    OSX has been in develpmant for years. i wish it was a bit beter. OSX DP 1 was released in like 1993</strong><hr></blockquote>

    it wasn't always like this. I don't think this happened back when I had OS 9 or 8.6 installed.

    it also doesn't happen when I take all my PCI cards out and allow my computer to go to "deep sleep"

    [ 01-06-2002: Message edited by: applenut ]</p>
  • Reply 3 of 7
    emaneman Posts: 7,204member
    That's weird. I never had that problem using 8.x-9.x.
  • Reply 4 of 7
    Don't know if this might be related to what you are experiencing...

    <a href=""; target="_blank">Macfixit coverage from 8/26/01</a>

    Wake-from-sleep and PCI cards Rick Sternbach writes: "The first time my G4/867 went to sleep under 9.2, I jostled the mouse and waited for the G4 to roust itself, but all I got was a nice blank gray screen sans pointer. Apple Tech support was contacted, asked me if I had installed any PCI cards; I had dropped in an Adaptec Ultra 160 card for two extra SCSI HDs, and the fellow said that's the problem, something about the PCI card and the power management of the PCI bus conflicting, and the best thing I could do was to set the sleep period to never."

    Update: Bob Leedom had this problem and was told the same thing by Apple. However, he also contected Adaptec. They told him to remove the currently installed Adaptec driver and install Adaptec SCSI Card 2906 Driver 1.3. This version of the driver adds enhanced support for the 133MHz system bus PowerMac G4 deep sleep mode. This worked.

    I recall reading somewhere else that certain PCI cards had conflicts with deep sleep mode on Macs. One option would be to pursue updated drivers/firmware from manufacturers. Another (less enviromentally friendly) option is just to turn sleep mode off. Based on my traumatic experiences supporting Windoze PCs I always turn it off anyway.
  • Reply 5 of 7
    enderender Posts: 353member
    I've never liked deep sleep on my desktop (love it on my Ti though). I set it so that the monitors turn off after a short time (5-10 minutes), the hard drive after a bit longer (15 minutes), and sleep never.

    Plus iTunes will keep playing then too

  • Reply 6 of 7
    applenutapplenut Posts: 5,768member

    here's the solution.. any of them do the trick

    [quote]I'm probably going out on a limb here. But let me guess, you have an internal Zip drive. There's a systemwide slowdown caused by a conflict b/t Apple CD/DVD Driver (v1.4.5 and 1.4.7) and Iomega drive/drivers -- most often seen after waking.

    Pick one of the following workarounds that suits your taste and usage:

    1. Stick a zip disk in when it slows, or leave it in full time -- use Iomega Drive Options c.p. to set up no eject on shutdown/restart.

    2. Disable Iomega Driver; use Iomega Guest to load as needed, disable it when done.

    3. Downgrade the Apple CD/DVD Driver to v1.4 -v1.4.4. (Don't use v.1.4.5 or 1.4.7). You can download here at the bottom.

    4. Disable Apple CD/DVD Driver.

    5. Disconnect the Zip drive. <hr></blockquote>
  • Reply 7 of 7
    I have had this same problem with my Yosemite and the culprit is indeed the Zip drive. Seems like the system bus doesn't fully wake from sleep if there is an internal Zip on it. To wake it I insert a Zip disk and eject it as soon as it mounts. Viola! System bus fully awakened, performance restored.
Sign In or Register to comment.