Help with my QPS drive.

in Genius Bar edited January 2014
Can you help me? QPS cannot. Here is my problem, copy and pasted from the email I sent them:

"I am using the above mentioned drive (model # QPS-525) and am having

difficulties with my computer once I am finished burning a CD.Â*

Everything works fine, but when the drive is finishing burning the disc,

my computer slows down to the point my only option is to restart.Â* It

takes several minutes just to close a window or click on a menu and have

the menu options appear.Â* About once out of every ten times I burn a CD

I do not have this problem---the CD mounts on the desktop and it appears

in the left side menu of iTunes along with the library and playlists.Â*

More often than not, however, I get the slowdown and am forced to

reboot.Â* Is there a way to alleviate this problem?Â* I would appreciate

any advice you may have."

They responded

"toasttitanium version 5.1 is reported by roxio as being 10.1.2 compatible

Â*Â*Â*Â*Â*any other legacy software or devices may cause problems in 10.1.2 investigate them as separate issues"

First off--what is legacy software? Thanks for explaining QPS. Ever think maybe not everyone that uses your products knows everything under the sun about computers? I sure don't...iTunes is Apple and TT is what is legacy???

This really doesn't help me. I cannot believe they respond by telling me TT is compatible with OSX. like iTunes isn't?????????

They are trying to hide a hardware problem as a software problem.

OK, maybe I am being harsh, but I am pissed that I spent big bucks on this drive and that is all I get as a response. Add to that it does not even address the issue at hand.

I would call, but the cheapskates do not even have a toll free #. you would think that if I spent $250 on their drive I could call them for tech support for free.

As for switching to TT...why should I? First of all, I have 1100+ songs in iTunes, playlists set up, the whole works...I spend a lot of time with it...I know it well, it is like second nature to me.

Plus, I do not have the cash to shell out for another burner, or the money to buy TT. And, I am not downgrading to a USB FireWire drive if I sold this one---I would not have enough $$ for another FireWire drive. It really pisses me off.

So, does anyone have a solution to the problem?

Have you had any issues with QPS? I have been browsing various message boards and have seen people post about problems but no real solutions.


  • Reply 1 of 2
    noahjnoahj Posts: 4,503member
    I Have a QPS QUE!Fire 12x10x32 and it works fine for me. No problems. I just last night burned 3 CD's from iTunes. Are you at the latest version of iTunes? That is all I can think of since i beleive you mentioned you were running the latest version of X, right?
  • Reply 2 of 2
    I'm not an expert, so I may be completely off, but it doesn't sound to me like a hardware problem. Legacy software refers to old versions of programs. They probably thought that you tried an old vers of Toast. I haven't tried burning at all with iTunes, or recently for that matter, so I don't know for sure, but it seems that it is the prob. If you're in X, you may want to try quitting/reopening iTunes, or [failing that] try apple's support site/msg boards. If OS 9, try giving iTunes more memory (get info on iTunes then inc. the memory boxes). It sounds to me like a leaky pointer, meaning that the program tried (and succeded) at overtaking memory, and not giving it up for other progs. It leaves less memory avail for other progs to do things, so they are using less space ~> more time. But, again, I'm not an expert.
Sign In or Register to comment.