iMac display problems

in Genius Bar edited January 2014
Well less than a week ago I bought a new iMac (15 inch 800mhz etc.) and something already went wrong (but otherwise I love it!)

My dad was playing around with iPhoto, and all of a sudden, vertical lines appear on the screen, and all the system-related icons (the third party app icons are ok) turned purple. I tried playing with the display settings, color settings, basically all the settings I could find in the preferences pane, but nothing works. Logging out doesn't work and nor does restarting. My fonts also have turquoise vertical lines through them. I once had a problem like this with my geforce2 on my pc, and thought it was a problem with the card, but that wouldn't explain only the system icons being screwed up. Also, if I run applications there are no lines through their backgrounds. For example, in safari now everything looks normal, background is normal, buttons are ok, smilies are, but the fonts aren't. Another weird thing is that the system icons turn ok again when I set them to full size (128x128 ) but anything below that turns purple with lines again.

I'm new to mac! What can I do??

If my description isn't sufficient I guess I could post a screengrab...


  • Reply 1 of 4
    paulpaul Posts: 5,278member
    well if only system related files are messing up (fonts and such) maybe a clean install would fix the problem... but first you should do routine maintenance checks that should be done regularly anyway...

    repair permissions using disk utility in the utilities folder then after everything is repaired you should do a 'fsck'... to do this you can do one of 2 things... boot up from your os X install CD (the first one) or reboot into single user mode and use the cli to run the command...

    if you choose the latter hold down "command s" on startup and you will see a black screen with a bunch of code... wait for this to load completely and type "/sbin/fsck -y" (minus the "s of course) this will run for a little while and most likely you will see a message stating the file system was modified afterwards... if you see this message type the command again. Do this until it says "the file system appears to be OK". after it says this type "reboot" to reboot the computer and it should start up normally...

    after it starts up and you still are having the problem, backup any files you want to save and do an archive install from the OS X installer CDs... if this works I suggest you "zero" the drive and re-install everything, just so you won't have the problem again... if it doesn't work (the archive install) chances are re-installing everything fresh wont help either and you should probably send it in to Apple to get fixed...

    let us know what you decide... and screen shots would help... but from the sounds of things something in the system is corrupt and is causing problems... I don't see why a clean install wouldn't fix things...
  • Reply 2 of 4
    pumpkinpumpkin Posts: 32member
    well I tried the fsck and disk tool but no success... I can't find my system restore disk atm, so I'm just looking around trying to find what's wrong... in the verbose startup mode (and in the command-S mode, whatever it's called) I noticed it says it was haveing problems with "NVDANV10HAL", which looks like a hardware abstraction layer for an NVD (nVidia NV10 = Geforce 2?)

    Could it be a problem with the nVidia drivers? Or am I too used to windows, and are drivers "obsolete" in OS X? :P


    Oh I forgot about the screenshots:

    Although they aren't perfect quality jpegs, most of the "artifacts" you guys see on the screenshots are due to my problem, and not to jpeg artifacts.

    EDIT (2):

    Argh just in case you guys aren't used to geocities pages, to access those images, you'll have to go to and in the file listing open purple.jpg and ok.jpg. It doesn't allow viewing of files from external referrers
  • Reply 3 of 4
    neutrino23neutrino23 Posts: 1,558member
    You have a warranty. Call Apple and let them sort it out. It sounds like a hardware problem to me.
  • Reply 4 of 4
    paulpaul Posts: 5,278member
    woah... ok yeah... if you cant find your install CDs you have a bit of a problem in addition to the purple icons..

    where is it? those CDs are pretty important... ok yeah... if you cant find them just call up apple... they will fix it, but they will want to know where your CDs are also...
Sign In or Register to comment.