Networking Problem

in Genius Bar edited January 2014
I'm trying to help my friend setup wireless in the apartment he just moved into as a summer sublet. He has a Linksys wireless/4-port switch router. This is the setup at the apartment (as he described over the phone) :

- ethernet jack on the wall (He tells me that the apartment has 'DSL', so I assume that the apartment complex has one large business DSL line and have a internal network sharing it over a range of IPs or something. Another friend has a similar setup to that in an apartment in the same area.)

- something that appears to be a router with a port labelled 'DSL' that is plugged into the wall jack and has 4 ports labelled 1-4 respectively and a 5th port next to them which I assume is a uplink port.

- His router which is a Linksys router that has a 4-port hub and wireless Access Point.

I've had him try many setups over the phone and none have worked. It works fine if he plugs a cat-5 cable into one of the ports (1-4) on the 'router' that is there, but he wants 'airport' for his iBook. Let's review some of the things that I've had him try so far. I will be painfully specific so that no one gets confused with 'are you sure that went into the right port' type questions.

Setup #1:

I've had him plug a cat-5 cable from a port on the 'router' that was there (one of the ports 1-4) into the WAN port on his router. This setup should work. The 'router' there should just see his router as another computer and his router should pick up an IP and such. Well, his router does pick up and IP and it picks up DNS and everything. But he still can't access internet. For some reason his router won't give him an IP address. He ends up with a 169.whatever IP address. Which he shouldn't. He should get a 192.168.1.* IP. I realize that this is a problem, but I figured that he could just ignore the DHCP. He manually configured his iBook for, and added in the DNS info and put his Router IP configured to (don't ask me why , but he wants the IP of his router to be set to this ... yes he set this in his iBook settings AND the settings on the router). This setup didn not work, even when bi-passing DHCP.

Setup #2:

I figured that "Ok, the router doesn't seem to work. maybe I can get the 4-port switch/Wireless Access Point to just Daisy-Chain to the hub/switch on the 'router' that is there." No dice here either. At first I told him to plug the uplink on his router into the first port on the 'router' there. No dice. That didn't seem right so I had him plug from the 'uplink' on the 'router' there into the first port of his linksys's switch (the uplink ports are next to the port 4 on both his and the one there). This didn't work either. In this config he got through DHCP an IP and a DNS, but no 'Router' (as the net config in System Preferences calls it, I'm more used to seeing it called the 'Gateway') was automatically configured. (In Setup #1 his router got a gateway from DHCP which was , I'm assuming that is from the 'router' that is there ... though) and when he tried to ping it told him there was 'no route to host'. I'm unsure of this configuration since I've never setup a 'daisy chain' of hubs/switches myself. Are you supposed to use a cross-over cable for it? :-\\

This entire thing has my baffled. Setup #1 should have worked. The WAN info was all correct, but DHCP wasn't working and the packets weren't routing for some reason. The only thing I can think of as far as the DHCP goes, is that since both routers might be having their internal DHCP servers conflicting or something. I don't *think* this is the problem, but I'm baffled as to what is. The only thing that I didn't have him do was reset everything to defaults


  • Reply 1 of 2
    pesipesi Posts: 424member
    it may very well be a DCHP problem. i set up a similar configuration once and was banging me head against the wall trying to figure it out until i remembered to turn DCHP off on the wireless router. that fixed everything.
  • Reply 2 of 2
    ebbyebby Posts: 3,110member
    Let me get this straight...

    He has a Ethernt jack in his house which is hooked up to a DSL line. Then he plugged a wireless router into another router that is connected to the main DSL router?

    It sounds like the apartment already has DSL and the landlord already installed a router to break it up for the apartments. If this is true, configure the Linksys router to get a dynamic IP (also labeled DHCP sometimes). REMOVE the other router and plug the Linksys DIRECTLY into the Ethernet jack in the wall. You don't really need 2 routers, right? (Keep the second router for LAN parties) 8)

    I have a Network everywhere router and a Asante router. I tried to plug them together like you did, but got nothing but problems.
Sign In or Register to comment.