FireWire is toast :(

in Genius Bar edited January 2014
i was plugging in my external drive (2.5 inch bus powered) and my computer (867 g4) suddenly shut off. upon restarting, i noticed that my ipod, nor my other external drive was mounting, yet the ipod was charging.

i opened system profiler and clicked firewire, only to see it say "No information found".

im assuming that my ports are dead and am going to buy a usb2/fw card, but i want to know if this may cause other problems for me


  • Reply 1 of 9
    billybobskybillybobsky Posts: 1,914member
    um, you should be careful about using that drive. Also, open the computer and check to see if there are any visible burn marks on the motherboard. Since your computer started it probably isnt anything to worry about now, i just wouldnt trust that drive.
  • Reply 2 of 9
    If the port was dead would the iPod still be charging?
  • Reply 3 of 9
    dmband0026dmband0026 Posts: 2,345member
    You can still get power from a "dead" port. The card can still be powered, but the connection between it and the logic board is broken somewhere. No connection to the logic board = drive won't mount.
  • Reply 4 of 9
    more problems, on remembering that i had to reset my clock after my mac shut itself down, i tried zapping the pram just in case it might do something, and sadly, it did.

    i now get sent straight to open firmware, witht the following message when i try to type "mac-boot":


    Default catch!, code=300 at %SRR0: ff849480 %SRR1: 0000b030

  • Reply 5 of 9
    shetlineshetline Posts: 4,695member

    Originally posted by ThunderPoit

    i was plugging in my external drive (2.5 inch bus powered) and my computer (867 g4) suddenly shut off. upon restarting, i noticed that my ipod, nor my other external drive was mounting, yet the ipod was charging.

    This sounds nastily similar to a recent series of events I experienced with a home-brew PC.

    I bought a case that had a front panel FireWire port. It took a little work to get that port connected because it didn't have a simple connector to plug into anything, it had six separate wires with individual pin-header connectors on each. I had to make a homemade adapter to connect the individual wires to a plug cut off the end of a spare FireWire cable.

    I proceeded to burn out both a cheap ($18) FireWire board and a (not so cheap) 20 GB iPod when I tried this port for the first time. The symptoms were just as you describe.

    I fixed the iPod by getting a friendly fellow AI-er to sell me an old 5 GB iPod with a broken drive for $40, connecting my 20 GB drive to the 5-gigger's electronics, a spending many, many hours and another $10 on finding the right tool (a Dremel diamond cutting wheel) to cut and adapt the steel part of the 20 GB iPod case to the plastic part of the 5 GB case.

    I had a one-of-kind FrankenPod, 20 GBs with push buttons and non-solid state scroll wheel, that was working for a total of maybe 6 hours...

    After double, triple, and quadruple checking my wiring, I tried the front panel FireWire port again. Result: Another dead FireWire card, a dead-again iPod.

    I went over the problem again and again and again. It was a total mystery until I discovered something completely by chance: a short registered between two of the leads to the front-panel port. I'd already checked many times for shorts, and hadn't see one, but this time I did.

    Eventually, I narrowed the short down to the FireWire port itself... nothing to do with my wiring or the FireWire cards I was using! The port itself had an intermittent short! I hate problems like that... the problem completely defied even the most careful testing, so no matter how careful I was, the short could be, and was, hiding from me until it was too late.

    The physical act of plugging in a connector turned out to be a great way to cause this short to occur, and even then, I had to monitor the two pins that were shorting out while plugging in a cable, because the short was typically only momentary while plugging the cable in.

    Perhaps you are experiencing a similar short circuit. One of the lines in a FireWire connector is for power, and it turns out that if this power lead accidentally gets fed into any one of the signal leads, it's a Bad Thing.
  • Reply 6 of 9
    what does default catch mean?
  • Reply 7 of 9
    ok, strangest thing happened, i tried booting off of my panther disk, was able to get past OF and chose my normal drive to boot from.

    i restarted, and now everything is fine, firewire ports and all. only thing thats not working is the belkin 3 port FW card i got :/
  • Reply 8 of 9
    alcimedesalcimedes Posts: 5,486member
    now and again i've seen firewire do this.

    you have to unplug and power down ALL devices that were connected in a chain.

    remove all firewire cables.

    power the machine up, then plug the drives back in one by one. suddenly everything is happy again.
  • Reply 9 of 9
    no matter what i do, i cant seem to get the belkin card i got to do anything, its very odd, think ill go get my 40$ back
Sign In or Register to comment.