Accessing shared iTunes through router

in Genius Bar edited January 2014
I have a Linksys router and now I can't share music with iTunes. I konw that I need to do port forwarding in the router setup. When I go in there I set it up as:

Start: 3689

End: 3689

I am not sure wether to check TCP or UDP protocol but I have TCP selected, and I have it being sent to which is what my computer is. Anyone have any suggestions, because I still can't get the share to work.

Also, would web sharing be set up the same way?

Thanks in advance.



  • Reply 1 of 25
    I think your doing too much here. Someone correct me if I'm wrong, but I don't think port mapping is necessary in order to share an internet connection/files on a network/iTunes shared libraries. Try resetting the router back to factory settings and just plug in and try again. Make sure your iTunes libraries are set up to share and that you have file sharing on in System Preferences/sharing. Don't make things harder than they have to be.

    In the future, questions like this should go in Genius Bar.
  • Reply 2 of 25
    1. I have sharing turned on.

    2. Factory settings don't work because I haven't done that much tinkering with it, so basically it is factory default.

    3. Correct me if I am wrong, but you do need port forwarding because all requests are going to the router and it doesn't know where to send the requests too.
  • Reply 3 of 25

    Originally posted by DCmac32

    1. I have sharing turned on.

    2. Factory settings don't work because I haven't done that much tinkering with it, so basically it is factory default.

    3. Correct me if I am wrong, but you do need port forwarding because all requests are going to the router and it doesn't know where to send the requests too.

    I have a Netgear wireless router set up at my house that is sharing a cable connection. I have basically factory settings as well, but no port mapping, no crazy IP address stuff, just the router. The request will get where it needs to go, you don't have to spell it out for your router. Port mapping is only if you want to run a computer as a dedicated server, has nothing to do with sharing iTunes libraries.
  • Reply 4 of 25
    kickahakickaha Posts: 8,760member
    Punch a hole through 3689 on the Firewall on your machine(s). Make sure it's open on the router too if you're running iTunes 4.0.0 w/ internet sharing, or have enabled that through one of the various hacks around.
  • Reply 5 of 25
    Lynksis router 3 macs 1 PS2, never did anything to the router and all works well. Since I am running a websever from my QS, I have http requests sent to the QS by port forwarding. This forwarding is for requests made from outside your LAN, in other words the WAN.

    But that is not your case, you should just plug in your comps and turn on whatever sharing prefs you want for each computer. So reset that router and give it a go. Oh, and make sure you have the sharing turned on in itunes prefs also.

    Good Luck, Randy
  • Reply 6 of 25
    Ok, so I took the router down and plugged my computer straight into the ethernet port and the iTunes sharing popped right up. So I reset the router and ran my computer back through it and I lost sharing again. I don't know why it's doing this. Anyone have any ideas, even if it's not port sharing what I can do? Thanks.

  • Reply 7 of 25
    dmband0026dmband0026 Posts: 2,345member
    Did you take Kickaha's advice? Firewall would be the next most likely culprit. Open up the right ports. In this case 3689. If you don't know how to do this, PM me or post it here and I'll be happy to walk you through it.


    Kickaha: I'm surprised at you, letting this slip through your fingers! This should probably be in GB, if not GB, than DH. If I'm wrong, I apologize and will take what's coming to me.
  • Reply 8 of 25
    kickahakickaha Posts: 8,760member
    I don't moderate this forum...
  • Reply 9 of 25
    DMBand0026 sorry about all the hassle, but I appreciate the patience and help. Here's what I have going on right now.

    I have the built in firewall ON and I have Personnal Web Sharing, Remote Login, FTP, iChat, and iTunes all On. In iTunes, I have 'Look for shared music' checked as well as 'Share my music'. Any ideas.

  • Reply 10 of 25
    jante99jante99 Posts: 539member
  • Reply 11 of 25
    Ok. That's what I have.
  • Reply 12 of 25
    Boof! Off to the Genius Bar!
  • Reply 13 of 25
    dmband0026dmband0026 Posts: 2,345member
    DCmac32, no prob, sorry I haven't been more of a help.

    Next I would try killing the firewall on any and all boxes your trying to share with. I don't know what that's gonna do, but it's worth a shot. Make sure your router doesn't have any built in firewalls or anything like that running on it, if it does, kill it and let OS X do the firewall work.
  • Reply 14 of 25
    As of right now, I only have one computer set up to the router. My PowerBook should be in by Friday, that's why I am trying to get this set up before then.

    I didn't find any settings for a built-in firewall for the router, but I did find a setting called 'Filtered Internet Port Range'. The options of this are Disable, TCP, UDP, and Both. I can then specify a beginning port and an ending one. I set the option to Both and set the ports from 0 ~ 65535, but it ended up blocking all traffic. Any ideas.

  • Reply 15 of 25
    kickahakickaha Posts: 8,760member
    'Filtered' could mean 'filtered *out*', ie, blocked.

    In which case 'Disabled' would mean 'don't block'.

    *shrug* Dunno. It's not like there's a standard terminology that these folks use. :P
  • Reply 16 of 25
    I would disable it. Opening all the ports wont really serve a purpose, so just disable it. How many computers do you have in your house now? Are they running wireless or what? You said earlier that you unplugged the computer and plugged it directly into the "ethernet port". Do you have a hardwire system running through your whole house?
  • Reply 17 of 25
    Why don't you disable the firewall on the Mac, and let the router's firewall take care of blocking the yucky stuff? I'm sure that's how the others are doing it, and why iTunes sharing is working. Works fine with my Asante router, for example.
  • Reply 18 of 25
    It sounds like you're trying to share your music from behind your router to computers outside it. You can't do this because Rendezvous is based on subnets, so simply routing external port 3689 to your internal port 3689 won't work. iTunes on your computer still thinks its IP is Other services such as web hosting and file sharing work fine with this kind of port forwarding, but Rendezvous-based services cannot be used from behind a NAT.

    Depending on your circumstances and why your are behind a router (is it just for wireless access?), you may be able to turn off the routing feature, uplink it to the rest of the LAN (formerly the WAN), and get your IP from the same DHCP server that's serving the rest of the computers you want to share with. That way you will be on the same subnet and all will be well.
  • Reply 19 of 25
    I shut off the built in mac firewall, but still nothing.
  • Reply 20 of 25
    Noleli2 is there anyway to do that other than taking down the router. The router is just for wireless access. So if I can keep the wirless connectivity and still be connected to the main subnet I would like to do that. Any advice.

Sign In or Register to comment.