Lacie firewire HD misbehaving, cause it can't be my fault.

in Genius Bar edited January 2014
Here's the situation:

I just got my new iMac G5. So I unhook my external Lacie HD (that has every file I need on it) from my TiBook, hook it up to the iMac... no problems.

Then I switch over to the guest account I created. I set permissions to no access because I don't want guests getting into my work files. No problems.

Switch back to my account. Resume playing song in iTunes i had fired up before logging in as guest. When the song ends, the external HD unmounts (so I think) unexpectedly. After fishing around, it looks like I've disbaled all ownership of the HD and it will mount, but I can't see it, or access it in any way. When I hook it back up to my old TiBook, I'm getting the same issue now.

Can someone let me know how I can reassign myself ownership so I can get at all my work files, music library, etc.? Already tried the Disk Utility route, and ran it through DiskWarrior, but have yet to have any success.


  • Reply 1 of 4
    rageousrageous Posts: 2,170member
    I took it into work and hooked it up to my Powermac, and it mounted fine. I just restored access to any user from there, and now it works again on the iMac.

    Problem solved.
  • Reply 2 of 4
    Hey, glad I could help
  • Reply 3 of 4
    argeliusargelius Posts: 309member
    I need to buy an external hard drive for my Powerbook for backup purposes.

    Anyone recommend an 80 GB firewire drive that will work. I'm hoping to get one that doesn't need a separate power supply...

    (And any online retailers you recommend).

    Mac Newbie here.

  • Reply 4 of 4
    I've used MacWarhouse years ago before we had decent Apple resellers in town.

    How about this? It's 100 GB & doesn't require an external AC power supply.
Sign In or Register to comment.