Help! Premature Powerbook Demise!

in Genius Bar edited January 2014
When I boot up my G4 PB, it sticks on the grey screen, at the point before the spinning grey circle appears. I figure that I might be able to fix this with a software restore, but the PB drive is also not reading any disks - it whirrs loudly and spits them out. Anyone know if it is possible to boot the G4 from an external drive, or using an iMac G5? Many thanks.


  • Reply 1 of 22
    Is it possible to hold Option on startup and get a screen where you can choose your startup disk? It is possible to start up from an external drive, once I actually used my iPod for the task.
  • Reply 2 of 22
    stanstan Posts: 32member
    Unfortunately, I can only view the grey screen on the Powerbook. This I am assured by some people who know more about these things than me is fixed relatively easily - by using the software restore disk.

    This was obviously the point when I discovered the problem with the disk drive not accepting any media. Hence the need for booting from an external drive. A bit of a 'catch 22' situation.

    What I need to find out is a) is it possible to boot from an external drive, b) if it is, do I need to input a set of key strokes to activate the boot up (bearing in mind I can't see the on-screen instructions, and c) is there a way I can control the PB from elsewhere so I can see what I am doing (eg another monitor, or my iMac G5). I have treid rigging my PB to an external monitor, via S-Video, but again only the grey screen appears, so this seems unlikely.

    Thanks for your feedback, any more would be most welcome. Cheers.
  • Reply 3 of 22
    Use FireWire target disk mode to boot the PowerBook's hard disk (the target computer) as an external hard disk on the iMac G5 (the host computer). Here's an article on Apple's site that explains FireWire target disk mode. Once your PowerBook is mounted on the other Mac run Disk Utilities to make sure the disk is good and then install a fresh copy of OS X.
  • Reply 4 of 22
    lundylundy Posts: 4,466member
    You've tried the usual steps of

    1. Zapping the PRAM

    2. Resetting the nvram

    3. Booting with the Option key down to get the Boot Selector firmware screen?

    4. Booting into single-user by holding down command-S during boot?
  • Reply 5 of 22
    Thanks for your help chaps. I will try this and let you know how I get on.
  • Reply 6 of 22
    stanstan Posts: 32member
    Ok, so tried zapping the PRAM, resetting the NVRAM, booting into single user mode and doing a safe boot - none of these worked, the grey screen on the PB remains.

    So, at present, have managed to log into firewire target disk mode and the PBook icon is on the G5 desktop. Opened disk utility to repair & verify the disk but when I attempt to do anything on the PB, an error appears: "Verify and Repair disk ? ?

    Repairing disk failed with error Could not unmount disk"

    An additional problem is that Filevault on the PB is turned on. At present, the only folders I can access are apps, library, system and users.

    1. Is there any way I can log into my account on the the PB?

    2. Is there any way I can view the PB desktop on my G5?

    3. How can i run a disk check with the above error?

    4. Is it possible for me to log into system preferences on the PB (NOT the G5) to turn off filevault on the PB. Apple's site seems to suggest this is possible but doesn't say how

    Many thanks for your help
  • Reply 7 of 22
    lundylundy Posts: 4,466member
    A long shot, but I had a similar situation once and solved it by deleting the files


    from /Library/Preferences .

    Booting into single user doesn't work?

    To do any of the things you mentioned on the Powerbook (remote login, etc), it would have to be booted, and from what you describe we have to get it booted first.
  • Reply 8 of 22
    stanstan Posts: 32member
    If I follow the path Powerbook - library - preferences the folder is empty! Even more confused now!
  • Reply 9 of 22
    One simple hint.

    There is a bug in Disk Utility, there are a couple of ways around it. First (what we've been doing) is to simply keep trying. After about the third try it will unmount the disk and go. The second option is to select the disk and click unmount a few times until it finally becomes gray. Then try doing the repair.

    Good Luck!
  • Reply 10 of 22
    lundylundy Posts: 4,466member

    Originally posted by stan

    If I follow the path Powerbook - library - preferences the folder is empty! Even more confused now!

    Me too. There is no Preferences folder in /System/Library/, so that isn't where you are looking.

    Is there ANYTHING in the /Library directory (folder)??

    And for some reason you absolutely cannot boot off the system DVD?
  • Reply 11 of 22
    stanstan Posts: 32member
    The Powerbook disk drive will not accept a disk at present. Not sure why this is. If I load the CD into the G5, I do not know how to boot the Powerbook with it from there.

    And now there's worse news! For some reason, when I boot pressing the T key now, the G5 is telling me that 'the disk you inserted was not readable by this computer'. If you choose 'initialise', disk utility opens, but the PB icon does not appear.

    This is driving me nuts now. Is there someway to run thge software restore from another machine? Or anything?!!!

    Thanks for your help and patience

  • Reply 12 of 22
    At one time you could mount the PowerBook drive in FireWire target disk mode and now you can't?
  • Reply 13 of 22
    stanstan Posts: 32member
    That's correct. I have now managed to get the G5 to recognise the volume on disk utility, it doesn't recognise it as the powerbook but just a 60gb drive. I have begun the process of flattening it (erasing the disk) in the hope that when this is complete I can reinstall OSX or use the software restall disk, if I can find a way to load the disk onto the Powerbook from the G5 drive. Any ideas would be welcome. Thanks,

  • Reply 14 of 22
    cj171cj171 Posts: 144member
    you can boot the install disc on the imac and install to the powerbook with it in firewire target
  • Reply 15 of 22
    Please could somebody explain how to do this, I am not sure. The untitled disk icon (formerly the PB) appears on the G5 desktop and in disk utility. I have placed the G4 PB software restore disk into the iMac disk drive, but can't see an obvious way of installing?
  • Reply 16 of 22
    Ok, so now I have the 'untitled' icon back on the G5 desktop. The PB is connected to the G5 via firewire targetting, the disk is completely erased, and all space is free. I have run first aid on the volume through disk utility and it now says all is fine.

    However, when I boot up the PB I still see only the grey screen. I presume this is because there is no operating system installed on the machine, so I still need to know how to install OSX onto the PB from the G5. I have installed the PB SW restore disk into the G5, but if I try to run it, it does not let me specify a volume, it just asks me to restart the machine to install. I have no way of knowing if it is going to reboot the G5 or the PB, so at the moment I'm not risking it. Looking for advice again chaps..!

    Many thanks

  • Reply 17 of 22
    Any ideas chaps? I'm stuck now!

    Many thanks,

  • Reply 18 of 22
    cj171cj171 Posts: 144member
    ok, put the powerbook into target mode and connect it to the imac. Then, put the restore discs into the imac and reboot, holding down c to boot off the restore disc. Then when choosing where to install, your powerbook should show up as a firewire drive in the choices, just pick that and it should install...hopefully it'll install the right stuff for the powerbook.
  • Reply 19 of 22
    lundylundy Posts: 4,466member

    Originally posted by stan

    Any ideas chaps? I'm stuck now!

    Many thanks,


    You know how to boot into FireWire Target mode, right?

    Hold down T on the PowerBook as it boots until you see the FireWire logo moving back and forth.

    Then boot to the CD on the other machine by holding down C as it boots. When you get to the installer, just tell it to install onto the PowerBook (which it will think is a FireWIre drive).
  • Reply 20 of 22
    stanstan Posts: 32member
    Thanks for your help, but unfortunately this hasn't worked. When I reboot my iMac, and hold down 'c', the system folder appears with the question mark, and doesn't reach the installer. I tried it first with the G4 PB restore disk so I thought that might be the problem, but now I have tried it again with OS X and it is still the same. After 30 seconds or so the G5 reverts to normal boot mode and starts up so no harm there - but I am still at a loss as to how to get OS X onto the PB. Any help welcome, thanks for your patience.
Sign In or Register to comment.