Help with Terminal and Quicktime

Posted:
in Genius Bar edited January 2014
Recently I have gained an interest in CLI interfaces and wanted to learn something about them with Terminal.app, but everytime I launch Terminal it launches Quicktime and then exits. This also happens when I launch a new shell of Terminal. How can I fix this? I have been using X11 to learn about the CLI, but I would like this problem to be resolved. Any help is much appreciated.

Comments

  • Reply 1 of 10
    kickahakickaha Posts: 8,760member
    Well that ain't right.



    Have you by any chance accidentally set files of extension .sh to open in QuickTime? Do a Get Info on one and see what it says to have open it.
  • Reply 2 of 10
    MarvinMarvin Posts: 14,232moderator
    Type open -a textedit ~/.profile in terminal and see what text is in there. That's if you use the default bash shell. If you use tcsh, it's in ~/.cshrc or something.
  • Reply 3 of 10
    lundylundy Posts: 4,466member
    Also, check under Terminal's Preferences menu to make sure that QT Player didn't get put in there as a default command.
  • Reply 4 of 10
    bpfltdbpfltd Posts: 12member
    Kickaha: I did what you suggested and the defaul app is textedit, so thats cool.

    Marvin: When I try to open that file terminal says:

    2006-03-25 09:47:12.368 open[280] No such file: ~/.profile

    [Process exited - exit code 1]

    and I'm pretty sure I'm using bash, because the other file name does not work.

    Lundy: I checked and it's not there as a default command.





    A friend of min suggested that I delete Quicktime's receipts, but I don't know where to find them.
  • Reply 5 of 10
    chuckerchucker Posts: 5,089member
    What does this give?



    open -a textedit /etc/profile
  • Reply 6 of 10
    bpfltdbpfltd Posts: 12member
    OK I did that, now what does it all mean?:

    # System-wide .profile for sh(1)



    PATH="/bin:/sbin:/usr/bin:/usr/sbin"

    export PATH



    if [ "${BASH-no}" != "no" ]; then

    \t[ -r /etc/bashrc ] && . /etc/bashrc

    fi
  • Reply 7 of 10
    chuckerchucker Posts: 5,089member
    Well, in any case, that's not related to QuickTime either.



    What's in /etc/bashrc ? Or in .bashrc?
  • Reply 8 of 10
    bpfltdbpfltd Posts: 12member
    Nothing that seems quicktime related
  • Reply 9 of 10
    lundylundy Posts: 4,466member
    Next step: Delete Terminal's preference file.



    /Users/youracct/Library/Preferences/com.apple.Terminal.plist



    Drag it to the Trash.



    Restart Terminal.
  • Reply 10 of 10
    bpfltdbpfltd Posts: 12member
    Did it, it worked. Thank you so much for your help, it is much appreciated.
Sign In or Register to comment.