How to make iPhone texts and iMessages appear across all your Apple devices

Posted:
in iPhone
One of the advantages of Apple's iMessage system is the ability to see and respond to iPhone texts across multiple Apple devices. AppleInsider shows you how to set up the feature and get messaging on your iPad, Mac and more.




Go into the Settings app on your iPhone, then scroll down until you find Messages. Assuming iMessage is on -- which it presumably will be -- the next step is to go into Text Message Forwarding.




Here you should see compatible devices signed into the same Apple ID, and you can toggle them on and off at will. This includes Macs and iPads, which of course don't normally handle SMS messages.

Next, go back up a level in Messages, then select Send & Receive. Be sure to set your phone number as both an origin and destination, rather than just an email address. You may have to add an email address to "You can be reached by iMessage at" in order to see "Start new conversations from" appear.




If you have an iPad, find the same Send & Receive menu within the Settings app, and make sure the information matches what was selected on your iPhone.

Mac owners should launch the Messages app itself, open up Preferences, and hit the Accounts tab. As long as you're signed into the proper Apple ID, the only thing needed here is to once again make sure origins and destinations are the same as above.




Be warned that while you might like the idea of receiving texts across multiple devices, there are potential problems.

On a basic level, if all of your devices are in the same room or house, several simultaneous notifications can create a cacophony. You might also prefer answering on a specific device, and/or want others to be distraction-free. Then there's the matter of privacy, since an iPad sitting on the couch might expose an otherwise private iPhone conversation.

Comments

  • Reply 1 of 13
    My iPhone does not have the text forwarding described for Messages in Settings. I have iOS 11.0.3. Why is that?
    SoundJudgment
  • Reply 2 of 13
    Great tips!
    I use iCloud's aliases to sort out which specific device gets and sends what. Use only a specific email alias per device, and add it to my address book with the device name.
    I have setup forwarding so that my iPhone will receive most of the texts/messages/chats/calls/FaceTimes/etc, as well as the specific device it was send to, except for my better-half's, that is.

    BTW, I have been an iTools/.Mac/MobileMe/iCloud user since the beginning, and have created several aliases back then, which it seems that you cannot create as many anymore now.
    edited October 2017 cornchip
  • Reply 3 of 13
    Jay7Jay7 Posts: 8member
    I don’t see Text Message Forwarding in Settings->Messages either. I have an iPhone 6. Is Text Message Forwarding only available on later iPhones or is it a carrier thing? (I have At&T).
  • Reply 4 of 13
    macguimacgui Posts: 1,157member
    siretman said:
    My iPhone does not have the text forwarding described for Messages in Settings. I have iOS 11.0.3. Why is that?
    It could be the particular model of iPhone you have. Mine is a 5s and it doesn't have that Text Message Forwarding option, nor the Show Contact Photos option show directly above it.
    repressthis
  • Reply 5 of 13
    mobirdmobird Posts: 111member
    siretman said:
    My iPhone does not have the text forwarding described for Messages in Settings. I have iOS 11.0.3. Why is that?
    I don't have this either. Running the latest Beta of IOS 11.1 that was released yesterday.
    iPhone 6s.
    repressthis
  • Reply 6 of 13
    Jay7 said:
    I don’t see Text Message Forwarding in Settings->Messages either. I have an iPhone 6. Is Text Message Forwarding only available on later iPhones or is it a carrier thing? (I have At&T).
    BTW I have the iPhone 7 Plus. 
    repressthis
  • Reply 7 of 13
    siretman said:
    Jay7 said:
    I don’t see Text Message Forwarding in Settings->Messages either. I have an iPhone 6. Is Text Message Forwarding only available on later iPhones or is it a carrier thing? (I have At&T).
    BTW I have the iPhone 7 Plus. 
    Make sure you are logged into your iCloud account.

    Reboot the phone.

    If that doesn't work, log out of iCloud and log back in.
    cornchip
  • Reply 8 of 13
    "Here you should see compatible devices signed into the same Apple ID, and you can toggle them on and off at will."

    Other devices may need to be logged in iCloud in order to make Text Message Forwarding appear. If there is no other device logged in to iCloud Text Message Forwarding may not appear, I guess.
    Dr.MORO
  • Reply 9 of 13
    I’m in the UK. I have iOS. 1.03 on an iPhone 7Plus. I don’t have this Forward messages option either. Hmmmm
  • Reply 10 of 13
    Oops my post above should say I’m running iOS 11.03
  • Reply 11 of 13
    I recently disabled my iMessage on my Mac because when I wasn't on my computer for awhile, sometimes days at a time (i don't leave it plugged in) I kept getting an insane amount of pop ups saying, "this message could not be sent." with the options "ignore, or try again"

    Obviously it wasn't syncing because it wasn't plugged in but it so annoying I just decided it wasn't worth the hassle anymore. It would totally interrupt what you were doing and you had to attend to the pop up for it to go away. 
  • Reply 12 of 13
    cornchipcornchip Posts: 1,246member
    Sort of old news as I've had this going on my '09 Mac Pro, iPhone 5s & iPad for years now.

    UPDATE: I say that, and now I can't log in to iMessage on my Mac at home...
    edited October 2017
  • Reply 13 of 13
    This has been an available feature for many versions of iOS - it is not new, it is a few years old. The requirement is that all of the devices - iPhones, iPads, Macs - all must be signed into you iCloud account. The forwarding list is a list of devices that have your iCloud account active. If the list is empty, then you are not signed in to iCloud.
    Dr.MORO
Sign In or Register to comment.