Anybody using 10.3 in a production environment?

Posted:
in macOS edited January 2014
I'm having lots and lots of problems with Panther at the moment.



I can't print anything from InDesign 2, PDFs from InDesign 2 come out wrong, Mail doesn't work properly, FontBook doesn't work properly (keeps hiding fonts as soon as I activate them), apps crash constantly (I get about three kernal panicks a day, the Address Book has never worked properly for me.



The PDFs from InDesign were working properly until one day when the just stopped. I've never been able to print anything from Panther to our postscript printer.



Anybody else had any problems like this? Or is it just my lucky month? I'm not looking for help ? I'd just like to know if anybody else out there is having the same problems?
«1

Comments

  • Reply 1 of 27
    ipodandimacipodandimac Posts: 3,273member
    machine specs please



    i just realized that was my 1000th post. i'm glad i made it extra special!
  • Reply 2 of 27
    pscatespscates Posts: 5,847member
    Here at work, we're still using 9.2.2



    But, for what it's worth, I'm using Panther at home, with the Adobe Creative Suite and have recently completed two freelance projects and was doing TONS of PDFs out of InDesign (for proofs) and sent the jobs to a printer and all went fine. And I've done lots of other smaller Illustrator/Photoshop work, where I've had to send PDFs to lots of people, print them off inkjets, provide some GIF/JPEG images, etc. Never had a problem with it, either from a Panther or Adobe standpoint.



    I've never had any problems with Mail and I use FontAgent Pro for font management, so I can't speak to those.



    I've actually had less problems with Panther and the Adobe CS than any other OS/software pairing in a decade.



    \



    Give some specifics, maybe, so people can help?
  • Reply 3 of 27
    hobbeshobbes Posts: 1,252member
    This is not normal behavior. I'd consider a reinstall with those kinds of issues. Also, consistent patterns of kernel panics can usually to be traced to either finicky RAM, quirky and/or legacy hardware set-ups, or bad hardware.



    BTW, I do not recommend Font Book for professional use, in its current state. Check out Suitcase X1 (w/ latest updates) or Font Agent Pro 2.
  • Reply 4 of 27
    airslufairsluf Posts: 1,861member
    Kickaha and Amorph couldn't moderate themselves out of a paper bag. Abdicate responsibility and succumb to idiocy. Two years of letting a member make personal attacks against others, then stepping aside when someone won't put up with it. Not only that but go ahead and shut down my posting priviledges but not the one making the attacks. Not even the common decency to abide by their warning (afer three days of absorbing personal attacks with no mods in sight), just shut my posting down and then say it might happen later if a certian line is crossed. Bullshit flag is flying, I won't abide by lying and coddling of liars who go off-site, create accounts differing in a single letter from my handle with the express purpose to decieve and then claim here that I did it. Everyone be warned, kim kap sol is a lying, deceitful poster.



    Now I guess they should have banned me rather than just shut off posting priviledges, because kickaha and Amorph definitely aren't going to like being called to task when they thought they had it all ignored *cough* *cough* I mean under control. Just a couple o' tools.



    Don't worry, as soon as my work resetting my posts is done I'll disappear forever.
  • Reply 5 of 27
    messiahmessiah Posts: 1,689member
    I don't want to turn this into a 'Genius Bar' thread, I was just wondering if anybody else out there was experiencing the same problems that we are.



    My current works machine is a 1.8GHz G5, with 512MB or RAM.



    I formatted the hard disk and installed the OS from the disc that came with the machine last week. The software was all installed from scratch for the original CDs. All the CDs are pristine. Software drivers were downloaded from the respective websites.



    I ran an extended hardware test and everything passed, so I doubt it's the RAM. Ever since I installed 10.3, the machine has just been a bundle of inexplicable bugs.



    I've just reinstalled Jaguar and things are a bit more stable now. Still won't print, but at least it's not KP'd so far?
  • Reply 6 of 27
    zozo Posts: 3,115member
    a) that sounds like wanky RAM. If you can, try taking out one, restart, see effects. Rinse, repeat with other stick



    b) sounds like possible mobo problem. You should get it checked at Apple store or something.



    I have been running 10.3 since it came out and had ONE KP because I was an idiot and deserved to have a KP.



    So, anyway... Panther is THE MOST solid release of any OS I've ever used (well, I cant ever recalling my C64 crashing... but whatever) and you shouldnt be getting problems like that



    10.3.3, G4-733MHz, 1.25GB RAM, and uncalculable amounts of HD space on USB, FW, double internal HDs.... and a 40GB iPod...
  • Reply 7 of 27
    Panther is rock-solid for me. It's the best OS from Apple ever.



    It's given me 99+% uptime. I've only had to force reboot ONCE and that was because I installed an NTFS-formatted drive and it hung once while trying to read some of the data. I suspect Apple's brand new drivers for NTFS aren't quite perfected yet; so, I forgive that. To be honest, I was surprised I could read it at all!



    I strictly use 10.3 on my Mac at home (dual G4).

    I strictly use 10.3 on my Mac at work (an older G3).



    Never any critical crashes, hangs, weirdness, etc.
  • Reply 8 of 27
    kraig911kraig911 Posts: 912member
    I use 10.3, are you using distiller to make your pdf's out of indesign, cuz if not you should, the new distiller makes thing somewhat back to the good ole OS 9 days. I use 10.3 no probs, you may want to reinstall dude, cuz taht sounds wierd. The only app I hear that has 10.3 problems is quark, so ummm thats all I can say. I mainly do TV production myself but still 10.3 has been good to me.
  • Reply 9 of 27
    dobbydobby Posts: 792member
    33 G4+G5's on 10.3.3 running X1 and CS.

    Only problem has been AFP2.0 on Helios (no long filenames).



    Dobby.
  • Reply 10 of 27
    kickahakickaha Posts: 8,760member
    Quote:

    Originally posted by Messiah

    I don't want to turn this into a 'Genius Bar' thread



    Why not?



    Quote:

    I ran an extended hardware test and everything passed, so I doubt it's the RAM. Ever since I installed 10.3, the machine has just been a bundle of inexplicable bugs.



    Just FYI, Apple's extended hardware tests do *not* test every aspect of RAM. GaugePro for Classic does, however. If you can boot into 9, run that just to make extra super special sneaky sure.



    Sounds to me like corrupted cached prefs somewhere... have you tried re*formatting* and reinstalling? Since you can't guarantee your old prefs, you're going to have to re-setup a lot of the machine, but hopefully it won't be too painful. \
  • Reply 11 of 27
    neutrino23neutrino23 Posts: 1,512member
    Aside from zapping PRAM, fsck and permission checks the thing that I've heard of related to this kind of crashing is a screwy font. I don't know why but an incompatible font will wreak havoc on OS X.



    Perhaps someone else can suggest which fonts are less X friendly, it is not my area. To test this you could remove all the fonts you have installed, test that the system is stable, install half, check for stability again, install half the remaining fonts, etc. till you find the one(s) causing trouble.



    I will add my comments to those above, Panther has been very stable for me. I don't think I've had even one KP on my 15" 1.25 Al PB since Panther was installed.
  • Reply 12 of 27
    messiahmessiah Posts: 1,689member
    Thanks for all the suggestions guys. It's interesting that 10.3 seems to be getting a clean bill of health. I run 10.3 at home and have never had any problems with it, but at work it's just turned into a fecking nightmare.



    So far, the font and the RAM suggestions seem the most likely leads. I'd reinstalled the machine from scratch (i.e. formatted the host drive) and then reinstalled the apps from scratch - so I'm fairly confident that it isn't a screwy pref file lurking around somewhere.



    Can you use Distiller in Mac OS X? I thought it was OS 9 only?



    I don't use distiller, instead I generate the PDFs directly from InDesign 2.0. As I say, everything was working fine on the PDF front until jobs started coming back with errors on the cromalins about a month ago. Since then, everything has had an error of some description (usually relating to transparency). If it was one print house then I would suspect they had changed something, but it's every print house we use so the problem must be at my end.



    A font problem would certainly explain why nothing prints from InDesign to our postscript printer. It would also explain why FontBook keeps "disappearing" fonts on activation. It might also explain why Acrobat Reader causes a KP about every fourth time I open a document. It wouldn't explain the problems we've been having with transparency in PDFs though.



    RAM - well it's just the two sticks that came with the machine I'm afraid. I don't have any other PC3200 RAM kicking around and obviously I can't just remove one, so I'm kinda screwed on that front. Likewise I can't boot into OS 9 to test the RAM from there.



    So much for buying legal software! Everything on that machine is bought and paid for - a rare occurence on a print production machine, eh?



    I suspect at this point, that there may be two or three problems with the setup, rather than just one single problem.



    Thanks again for all your suggestions guys - they are helping - keep em coming!



  • Reply 13 of 27
    costiquecostique Posts: 1,084member
    From my personal experience of trying to use Panther at work:
    • Be careful when you turn off fonts supplied by Apple: they may be required by certain apps which will misbehave without them.

    • Switch to Adobe CS. CS versions of Illustrator and InDesign are far superior in terms of stability and speed.

    • Max out your RAM: Photoshop doesn't really seem to adore OS X virtual memory management and when they both go swapping simultaneously, it drives me crazy.

    • Restart regularly (once a week, at the very least). I know I'm going to be flamed for this, but I have a gut feeling that large swap files tend to slow Panther down with time.

    • Get a CPU monitor (like MenuMeters). Too many apps devour CPU cycles when they are visible, so seeing which ones are greedy will help you develop a habit of hiding certain apps.

    [Edit:] And Distiller 6 is much faster than versions 4 or 5, though it has some harmless bugs with memory leaks.
  • Reply 14 of 27
    Quote:

    Originally posted by Hobbes

    BTW, I do not recommend Font Book for professional use, in its current state. Check out Suitcase X1 (w/ latest updates) or Font Agent Pro 2.



    I'd be mighty suspicious of Font Book as well. Screwy PDFs cannot be due to bad RAM.



    I'm using ID 2 and Panther as well and have had zero issues with printers - print shops or the networked variety. We don't use enough fonts to bother with a font management solution and for that I have always been grateful. It's just one more thing twisting your system's innards.
  • Reply 15 of 27
    ionyzionyz Posts: 491member
    I've only just begun using Fontbook, and that was only to turn off a few asian fonts, so I can't comment on it. Overall Panther has been very responsive and stable on my work machine (Stock G4 450 Cube w/ GeForce 3).



    Upgrading RAM to 1.5 GB did smooth things out, as sometimes everything would just slow down to a crawl and some apps would hang. Since I run a 450, CPU monitors are my friends. Didn't need them as much when I ran duals but with singles it helps explain the pauses and killing rouge processing eating up cycles.



    Turning off the machine frequently may also help matters. Since I'm running a very hot video card (GeForce 3) in a stock Cube (no fan) I never want to leave the system on when I'm not around. A tremendous amount of heat is expelled from the top and my work area leaves a lot to be desired. I keep a stack of papers perviously close to the top of the Cube.
  • Reply 16 of 27
    cowerdcowerd Posts: 579member
    still not enough info to troubleshoot.



    1. FONTS: reinstall all fonts used from originals. OSX is much pickier about fonts than OS9. Worse case scenario for troubleshooting: you add fonts until the machine fscks up. You just found your bad font.



    Some fonts (you haven't said a thing about them) won't allow embedding in PDFs. Fonts by Tiro are an example.



    2. Short of RAM for a production machine. Add RAM.



    3. PDF transparency doesn't work well. Flatten all PDFs to ensure correct results for press or even proofs.



    4. What other peripherals are on the machine? USB hubs have been known to be very problematic.
  • Reply 17 of 27
    I agree with the font issue - sounds like you have a font (or several) that are fine on 9 but causing issues in 10.3.



    I have 10.3.3 at home on a Dual G4/450, with the full Adobe CS suite and it makes PDFs flawlessly that print both on my Apple LaserWriter Pro 600 at home and on our imagesetter at work. I use Suitcase, not FontBook. FontBook seems to be fine for personal use in its current state, but not for production work (at least not yet).



    I use 10.2.8 at work on a Sawtooth G4/450, again Suitcase and Adobe CS suite, no problems with PDFs to our LaserWriter Pro 630 or the imagesetter.



    Run FontDoctor X if you have or can get hold of it. It seems to find/fix issues with fonts that worked just fine in 9.
  • Reply 18 of 27
    dobbydobby Posts: 792member
    Quote:

    Originally posted by Messiah



    Can you use Distiller in Mac OS X? I thought it was OS 9 only?





    You get Distiller with Acrobat 6.0 and it runs soo well. Our Dual 1.25 on 10.2.8 ripped a 800MB PS in 4 minutes and that went down to 1 minute with 10.3.2 installed (haven't put on the latest patch).

    Upgrade to CS and you get the whole lot for alot less than Quack 6.0.



    As far as your printing to the postscript printer.

    Reboot you system and withour having any font program running just print a simple hello from text pad. Or save this as a pdf and print from preview. Does this work.

    Are you sure the ppd is correct (the OS 9 PPD should be fine).



    Dobby.
  • Reply 19 of 27
    messiahmessiah Posts: 1,689member
    Hi guys, thanks again for the feedback.



    Unfortunately, the fonts problem is unrepeatable - i.e. it never seems to affect the same font twice. Restarting normally fixes the propblem. I've even had the problem occuring with Helvetica Neue, which is included with Panther. The only font I have that absolutely refuses to work with FontBook on every occasion is Swiss 721, which is one of my favourite fonts.



    We're considering moving up to the CS suite, but everytime we upgrade software it only seems to bring new glitches to the party. I'd love to be able to preview seps. Do you know if there is a way of inspecting a HiRes PDF to tell how may plates it has? I'd love to be able to do this for my own peace of mind.



    Cowerd, thanks for your comments about transparency in PDFs. I was starting to suspect that myself. My question to you is: if you are working in a two colour job, does flattening a transparent area convert the document into in a CMYK file, or do the spot colours remain intact?



    I've also had problems pasting between Illustrator and InDesign. If I create an element in Illustrator that is PMS327C for arguments sake, as soon as I copy and paste that element into InDesign, the PMS327C in InDesign changes to a spot colour that has CMYK values. I've never been able to figure out if this will result in a spot plate (that simply has the CMYK values attached), or if that colour is actually now a process colour. It certainly prints from my colour printer as a process colour. \



    I'm not convinced that the PPD I am using is fantastic. We have a Minotla QMS Magicolor 2350 for general in-house work. It rarely prints from InDesign. I normally have to PDF a document and then print from that.



    This is great - these are all questions I've had a back of my mind for a while now, it's nice to finally get some knowledgeable answers!



    Thanks again guys!
  • Reply 20 of 27
    moogsmoogs Posts: 4,296member
    Been using 10.3.x on a dual G5 with 2GB of RAM since November.



    Use all of the Adobe CS apps on a regular basis other than Illustrator, and occasionally other apps like Photo-to-Movie.



    The only problems I've experienced are random crashing by GoLive CS (which subsequently also brings down Photoshop for some reason). I believe both problems to be Adobe-related based on my observations, but I can't be sure. Generally though, I find it more than stable enough, and all of the 3rd party plugins we use (Dfine and Mask Pro for example) are Panther-compatible.
Sign In or Register to comment.