Lion will not run many applications

Posted:
in macOS edited January 2014
Lion looks nice.

However it will not run Power PC compatible applications.



For me this included several games, aol mail, an elderly version of Microsoft office, and Quicken 2007. They all work ed on Snow Leopard but I will now have to purchase them again.



Maybe I should have know this but I think there should HAVE BEEN A WARNING IN CAPS about this before the installation, so I could have made a more informed choice.
«1

Comments

  • Reply 1 of 25
    mr. memr. me Posts: 3,221member
    Quote:
    Originally Posted by Graham Reeves View Post


    Lion looks nice.

    However it will not run Power PC compatible applications.



    For me this included several games, aol mail, an elderly version of Microsoft office, and Quicken 2007. They all work ed on Snow Leopard but I will now have to purchase them again.



    Maybe I should have know this but I think there should HAVE BEEN A WARNING IN CAPS about this before the installation, so I could have made a more informed choice.



    Oh, please. This has been well-publicized for months. Basically, this was covered in almost all reports on the new OS since it was announced. It is clearly spelled out in the documentation that accompanies the Lion installer. What is more, Rosetta was not part of the default installation of Snow Leopard. It was an optional installation. Seen in this light, you have had years of warnings that PPC support in MacOS X was going bye-bye. The bottom line is that there is absolutely positively zero (0) excuse for not knowing that Rosetta is not supported under Lion.
  • Reply 2 of 25
    mysticmystic Posts: 514member
    Aol!?
  • Reply 3 of 25
    tallest skiltallest skil Posts: 43,399member
    Quote:
    Originally Posted by Graham Reeves View Post


    Lion looks nice.

    However it will not run Power PC compatible applications.



    For me this included several games, aol mail, an elderly version of Microsoft office, and Quicken 2007. They all work ed on Snow Leopard but I will now have to purchase them again.



    Or maybe you should use software less than half a decade old.



    AOL. Seriously.



    Quote:

    Maybe I should have know this but I think there should HAVE BEEN A WARNING IN CAPS about this before the installation, so I could have made a more informed choice.



    Or you could have read some of the articles that stated this fact that have been written over the last six months.
  • Reply 4 of 25
    _ alliance __ alliance _ Posts: 2,070member
    To be fair, most people don't scour the internet reading the latest rumors and crap regarding their computer. Most people will see there's a new version of something and since it's the newest, latest, and greatest will upgrade based on that alone. Most people, for better or worse, have no desire to put much effort into researching what will and will not work after an upgrade like this. I didn't realize this, and I scan this site a couple times a week (no, I don't scour each article). If I hadn't read a few threads on here before upgrading I would have been royally screwed, since my primary office management program is PPC apparently.

    The guy started a legitimate thread, IMO. Yes, the information is out there, but does that mean that everyone SHOULD know that information prior to upgrading? Yes, they probably should, but you all are part of the small percentage that actually does...
  • Reply 5 of 25
    mr. memr. me Posts: 3,221member
    Quote:
    Originally Posted by _ alliance _ View Post


    ... Yes, the information is out there, but ...



    No buts. The information was not just out there. It has been on this forum for the past six months. It has been widely discussed. "I don't read" is simply not an excuse. No one was required to upgrade to Lion. If you make a deliberately uninformed decision to do so, then you must accept to consequences of your decision. You have no one to blame but yourself.
  • Reply 6 of 25
    You will be surprised to hear that I have been a Mac user for over 25 years, I do try and keep up with the Mac press, and in particular this forum.



    Somehow this went right by me in my enthusiasm to get my free Lion upgrade on my newly purchased iMac.



    Was not surprised about old games etc, but do care about MS Office and Quicken.

    Would have been nice to have a list of things that would not work.



    Am assuming the newer versions of MS Office will work and it is about time I upgraded

    Meantime, it does look like most of my files can be accessed correctly by their iWork equivalents.



    Unfortunately Quicken is a problem..

    As you point out there are many posts that I see now, showing Intuit are not providing a version that is as complete as Quicken 2007. Luckily I have a laptop that is not yet converted and backups so can retrieve the Quicken data and hopefully export it into something else. I think many people will be caught out by this.
  • Reply 7 of 25
    _ alliance __ alliance _ Posts: 2,070member
    Quote:
    Originally Posted by Mr. Me View Post


    No buts. The information was not just out there. It has been on this forum for the past six months. It has been widely discussed. "I don't read" is simply not an excuse. No one was required to upgrade to Lion. If you make a deliberately uninformed decision to do so, then you must accept to consequences of your decision. You have no one to blame but yourself.



    Like I said, most people don't read message boards about the new operating system. They don't read every damn article talking about. Most people have lives. They see there's something new, maybe read up on if their computer supports it and all the cool new things it has, and then buy it. Get over yourself and stop being an asshole to the guy.
  • Reply 8 of 25
    mysticmystic Posts: 514member
    reinstall snow leopard.
  • Reply 9 of 25
    _ alliance __ alliance _ Posts: 2,070member
    Quote:
    Originally Posted by Mystic View Post


    reinstall snow leopard.



    I concur. It's not that big a deal. For the OP and for those upset about the OP.
  • Reply 10 of 25
    aquaticaquatic Posts: 5,602member
    Was there a valid reason not to include Rosetta? I wonder if some enterprising Mac hacker will eventually port it over.
  • Reply 11 of 25
    mr. memr. me Posts: 3,221member
    Quote:
    Originally Posted by Aquatic View Post


    Was there a valid reason not to include Rosetta? I wonder if some enterprising Mac hacker will eventually port it over.



    Presumably, Apple could include emulators that allowed users to continue to use legacy software that dates all the way back to the original 128 K Mac. Any decision to drop support for any version of the OS will leave some elements of the installed base high and dry. In my case, two mission critical applications prevent me from going totally to Lion. For one, the developer dropped support for the Mac with MacOS 9. For the other, the developer dropped support for the Mac prior to the Intel transition. In both cases, the developer continues to develop for Windows. I can't just abandon the applications because it would mean abandoning files that date back to 1989. But, I digress...



    Apple began the Intel transition in 2006--two computer lifetimes ago. Does this constitute a mandate to drop Rosetta? Of course not. However, Apple under Steve Jobs II is about the future, not the past. New technologies are adopted, old ones abandoned, and Apple makes money faster than the Government can print it.



    I may love my iPhone, iPad, and MacBook Pro. I may wish that Apple continues to support the technologies that enable software whose developers long ago abandoned them. However, the bottomline is the bottomline. The bottomline is that Apple is following a strategy that is now projected to carry it past ExxonMobil as the World's highest capitalized company.



    Think of the alternative. IBM lost its lead in Intel-based PCs partially because it insisted on continued support for the Intel 286 processor. If you run Windows, then you may continue to run commandline MS-DOS applications. Microsoft now fades in Apple's rearview mirror. However, memories of slavery to the the past are still fresh in the memory of Apple. The thing that brought Apple to its knees in the 1990s was its insistence that System 8 [Copland] be 100% compatible with System 7 while also supporting all of the marvelous new technology that Apple intended to incorporate into the new OS.



    Engineering is about design choices. None comes without a price. What we have seen is that we may abandon the past. However, the risk is that we may alienate the installed base. The alternative is to do everything that we can to support the installed base. The risk is that we are passed by competitors who are not encumbered by legacy support.



    Is there a reason that Rosetta was removed from Lion? Yes, the bottomline.
  • Reply 12 of 25
    banchobancho Posts: 1,517member
    Quote:
    Originally Posted by _ alliance _ View Post


    Most people will see there's a new version of something and since it's the newest, latest, and greatest will upgrade based on that alone.



    How does this explain the collection of old software he wants to run?
  • Reply 13 of 25
    mcarlingmcarling Posts: 1,106member
    Quote:
    Originally Posted by Aquatic View Post


    Was there a valid reason not to include Rosetta?



    The consequences of trying to maintain support for obsolescent and obsolete software is bloat, leading to poor performance and ultimately . If you think 10.7 not supporting Rosetta caused pain, wait until 10.8 drops run-time support for Carbon apps.
  • Reply 14 of 25
    MarvinMarvin Posts: 14,671moderator
    Quote:
    Originally Posted by mcarling View Post


    The consequences of trying to maintain support for obsolescent and obsolete software is bloat, leading to poor performance and ultimately . If you think 10.7 not supporting Rosetta caused pain, wait until 10.8 drops run-time support for Carbon apps.



    It helped slim down the installer too - just 3.5GB now. Not quite as lean as Ubuntu at <700MB but still downloadable.



    Now that it is a download package, hopefully they will find other parts they can trim or leave for a later download so the initial download goes more quickly.



    With PPC removal, I expect some of the bigger apps to have compatibility problems. Possibly not to do with PPC but Maya is not ready for 10.7 for example:



    http://forums.autodesk.com/t5/Instal...a/td-p/3098198



    I like it when legacy code is removed in general. It's been 6 years now since the Intel switch and they aren't going back. When we all have 64-bit, resolution-independent, inexpensive Cocoa apps we'll probably be better off.



    For the odd legacy app, there will be a Windows app that can run in a VM, including Freehand.
  • Reply 15 of 25
    mysticmystic Posts: 514member
    And again when they switch to a 128 bit OS.. And then a 256 bit OS......512 bit OS.......
  • Reply 16 of 25
    dr millmossdr millmoss Posts: 5,403member
    Quote:
    Originally Posted by _ alliance _ View Post


    Like I said, most people don't read message boards about the new operating system. They don't read every damn article talking about. Most people have lives. They see there's something new, maybe read up on if their computer supports it and all the cool new things it has, and then buy it. Get over yourself and stop being an asshole to the guy.



    Clearly you don't get it. If you're not a total geek you deserve to get screwed. If you ever forget this principle our many resident geeks will be happy to remind you.
  • Reply 17 of 25
    dr millmossdr millmoss Posts: 5,403member
    Quote:
    Originally Posted by Marvin View Post


    I like it when legacy code is removed in general. It's been 6 years now since the Intel switch and they aren't going back. When we all have 64-bit, resolution-independent, inexpensive Cocoa apps we'll probably be better off.



    For the odd legacy app, there will be a Windows app that can run in a VM, including Freehand.



    Talk to Intuit about how long they've had to produce an Intel binary for Quicken. They are not ashamed. The workaround of running Quicken for Windows would be kludgy and expensive, even if it worked -- which it doesn't. Quicken for Windows does not import Quicken for Mac files. So screwed city is apparently the place to be. So say all the cool kids.



    We run our invoicing system on an older version of FileMaker. Can we buy an Intel version of Filemaker? Sure, at a cost of $300 per workstation. Nice. That $29 Lion upgrade sure was a bargain.
  • Reply 18 of 25
    areseearesee Posts: 776member
    Quote:
    Originally Posted by _ alliance _ View Post


    To be fair, most people don't scour the internet reading the latest rumors and crap regarding their computer. Most people will see there's a new version of something and since it's the newest, latest, and greatest will upgrade based on that alone. Most people, for better or worse, have no desire to put much effort into researching what will and will not work after an upgrade like this. I didn't realize this, and I scan this site a couple times a week (no, I don't scour each article). If I hadn't read a few threads on here before upgrading I would have been royally screwed, since my primary office management program is PPC apparently.

    The guy started a legitimate thread, IMO. Yes, the information is out there, but does that mean that everyone SHOULD know that information prior to upgrading? Yes, they probably should, but you all are part of the small percentage that actually does...



    If your getting your Mac news from this site only you are screwed. This is a rumor site and as such most of what's said has to be taken with a large grain of salt and a very good BS detector. You should also be reading true Mac news sites like MacWorld (http://www.macworld.com/), The Mac Observer (http://www.macobserver.com/) and TidBITS (http://www.tidbits.com/). None of these are rumor sites and were all screaming about the lost of Rosetta and other issues. One or more of these sites (and there are others I haven't mentioned) should be on your must read list.
  • Reply 19 of 25
    mysticmystic Posts: 514member
    Quicken Essentials runs just fine in Lion.
  • Reply 20 of 25
    dr millmossdr millmoss Posts: 5,403member
    Quote:
    Originally Posted by Mystic View Post


    Quicken Essentials runs just fine in Lion.



    Quicken Essential is trash. It doesn't even print checks or do reports, something every version of Quicken has done for 15 years.
Sign In or Register to comment.